[XBLFC] Does not display items to select when option group category headings are used in a multiple selection list box with size attribute > 1.

VERIFIED DUPLICATE of bug 130115

Status

()

Core
Layout: Form Controls
VERIFIED DUPLICATE of bug 130115
16 years ago
16 years ago

People

(Reporter: TucsonTester3, Assigned: Brian Ryner (not reading))

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.9+) Gecko/20020320
Netscape6/6.2.1+
BuildID:    2002032003

A list box with option group category headings used in a multiple selection list
box with size attribute > 1 does not display items to select when using browser
with xbl enabled.

Reproducible: Always
Steps to Reproduce:
1.  Launch browser.
2.  Go to edit -> preferences -> debug and select
"Use XBL-based form controls (takes effect after restart). These are still under
constructions." 
3.  Go to a page that uses a multiple selection list box with size attribute > 1
where category heading are used, such as the attached reduced test case.

Actual Results:  A box is displayed, but the box only contains the default
selected item.  

Expected Results:  The box should display all of the items and option group
category headings specified in the html code.
(Reporter)

Comment 1

16 years ago
Created attachment 75583 [details]
Test case demonstrating that multiple selection box  displays properly when no option group headings are used, but does not  display properly when option groups are used.
Please assign XBLFC bugs to bryner@netscape.com
Assignee: rods → bryner

Comment 3

16 years ago
dup of 130115

*** This bug has been marked as a duplicate of 130115 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.