Closed Bug 1328058 Opened 3 years ago Closed 3 years ago

Tab displays "play" button or sound indicator when the only media element is playing and has no sound

Categories

(Core :: Audio/Video: Playback, defect)

52 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla54
Tracking Status
firefox51 --- unaffected
firefox52 --- unaffected
firefox53 --- unaffected
firefox54 --- verified

People

(Reporter: arni2033, Assigned: alwu)

References

Details

(Keywords: regression)

Attachments

(5 files)

>>>   My Info:   Win7_64, Nightly 53, 32bit, ID 20161119030204 (2016-11-19)
STR_1:
1. Open attached "testcase 1" in a new background tab
2. Switch to that tab

AR:  "Play" button is still displayed
ER:  "Play" button should disappear. No sound indicator, as there's no audio


STR_2:
1. Open attached "testcase 1" in a new background tab
2. Click on "Play" button in the tab opened in Step 1

AR:  Tab displays sound indicator
ER:  "Play" button should disappear. No sound indicator, as there's no audio

This is regression from bug 1308153. Regression range:
> https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=7ef35cccfd7b37a69354f08bfa4d118e4fcc4dd3&tochange=422c83e9e3be7c82e63ffdd43ad7ffc997975e0e@ Alastor Wu [:alwu]:
It seems that this is a regresion caused by your change. Please have a look.
No longer blocks: 1277113
Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core
@ Alastor Wu [:alwu]:
It seems that this is a regresion caused by your change. Please have a look.
Flags: needinfo?(alwu)
Assignee: nobody → alwu
Flags: needinfo?(alwu)
Blocks: 1308154
Comment on attachment 8827844 [details]
Bug 1328058 - part1 : notify block-stop event when the tab was resumed.

https://reviewboard.mozilla.org/r/105432/#review108556
Attachment #8827844 - Flags: review?(amarchesini) → review+
Comment on attachment 8827845 [details]
Bug 1328058 - part2 : rename function.

https://reviewboard.mozilla.org/r/105436/#review108558
Attachment #8827845 - Flags: review?(amarchesini) → review+
Comment on attachment 8827846 [details]
Bug 1328058 - part3 : don't show the sound indicator for video with silent audio track

https://reviewboard.mozilla.org/r/105438/#review108560
Attachment #8827846 - Flags: review?(amarchesini) → review+
Comment on attachment 8828227 [details]
Bug 1328058 - part4 : add tests.

https://reviewboard.mozilla.org/r/105690/#review108562
Attachment #8828227 - Flags: review?(amarchesini) → review+
Pushed by alwu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/61dbcbe35565
part1 : notify block-stop event when the tab was resumed. r=baku
https://hg.mozilla.org/integration/autoland/rev/b369d9999b8a
part2 : rename function. r=baku
https://hg.mozilla.org/integration/autoland/rev/0c177bdf5ec3
part3 : don't show the sound indicator for video with silent audio track r=baku
https://hg.mozilla.org/integration/autoland/rev/37d35ca95b1f
part4 : add tests. r=baku
Duplicate of this bug: 1335063
Pushed by philringnalda@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/0c48cff3db5d
followup, address eslint's concerns about a single-quoted string on a CLOSED TREE
Pushed by alwu@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d6b9226332b3
part1 : notify block-stop event when the tab was resumed. r=baku
https://hg.mozilla.org/integration/autoland/rev/4ac8a20b3297
part2 : rename function. r=baku
https://hg.mozilla.org/integration/autoland/rev/bd89482d13b7
part3 : don't show the sound indicator for video with silent audio track r=baku
https://hg.mozilla.org/integration/autoland/rev/c3c9a685ec6e
part4 : add tests. r=baku
Please request Aurora/Beta approval on this when you get a chance.
Flags: needinfo?(alwu)
Flags: in-testsuite+
Version: Trunk → 52 Branch
Flags: qe-verify+
I have tested the attached test case and it's fixed. However I can reproduce the issue in some youtube videos, but I'm not sure whether the video has audio track or not. If I mute the video the tab sound indicator disappear.
Also I`m unable to reproduce the issue in Vimeo.com or DailyMotion.com

https://www.youtube.com/watch?v=vhqnIWyNV6c (10 hours black screen, no sound)
https://www.youtube.com/watch?v=pg7b2NjKxjI (Lava Lamp HD (No audio))

If you think this issue needs to be reopen, please feel free to do so.
(In reply to Stefan [:StefanG_QA] from comment #31)
> I have tested the attached test case and it's fixed. However I can reproduce
> the issue in some youtube videos, but I'm not sure whether the video has
> audio track or not. If I mute the video the tab sound indicator disappear.
> Also I`m unable to reproduce the issue in Vimeo.com or DailyMotion.com
> 
> https://www.youtube.com/watch?v=vhqnIWyNV6c (10 hours black screen, no sound)
> https://www.youtube.com/watch?v=pg7b2NjKxjI (Lava Lamp HD (No audio))
> 
> If you think this issue needs to be reopen, please feel free to do so.

Don't need to reopen this bug, because both video are with audio track.
We won't enable the feature on 52, but I'm not sure we want to enable that on 53 or 54.
Keep NI, I'll discuss what version we want to enable the feature with my manager and EPM.
Alastor, could you please clarify for me how the check for "has sound" is done?

The reason for which I'm asking this is that I verified the testcase attachment and it seems that it has an audio track: verified with FFprobe:

~/Desktop$ ffprobe -i "testcase 1 - no sound (zero audio).webm"
Metadata:
    encoder         : Lavf56.40.101
  Duration: 00:00:09.97, start: 0.000000, bitrate: 180 kb/s
    Stream #0:0: Video: vp8, yuv420p, 1280x1024, SAR 1:1 DAR 5:4, 30 fps, 30 tbr, 1k tbn, 1k tbc (default)
    Stream #0:1: Audio: vorbis, 48000 Hz, stereo, fltp (default)

--------------
~/Desktop$ ffprobe -i "testcase 1 - no sound (zero audio).webm" -show_streams 2>&1 |grep 'Stream #0:1'
    Stream #0:1: Audio: vorbis, 48000 Hz, stereo, fltp (default)
Oh, sorry, the comment31 is not related with "has audio track or not". You can see the speaker still display when you're playing the "Lava Lamp HD", that is because the video didn't clear its audio track completely, it still has some weak audio signal. The speaker icon would show if the audio track has ANY signal, even it's too weak to hear by user. (And this is website issue) In addition, I don't see any incorrect situation when playing "10 hours black screen".

---

(In reply to Simona B [:simonab ] from comment #34)
> Alastor, could you please clarify for me how the check for "has sound" is
> done?
> 
> The reason for which I'm asking this is that I verified the testcase
> attachment and it seems that it has an audio track: verified with FFprobe:

Yes, the video has audio track but the track is silent , it doesn't contain any signal.

You can check it with Audacity, to check its wav data.
Flags: needinfo?(alwu)
Did you want to request Aurora approval on this?
Flags: needinfo?(alwu)
The feature will only be enable after FF54, so we don't need to uplift this change.
Flags: needinfo?(alwu)
I have reproduced this bug with Nightly 53.0a1 (2016-11-19) on Windows 10 , 64 Bit!

This bug's fix is verified with latest Nightly!

Build   ID : 20170222030329
User Agent :   Mozilla/5.0 (Windows NT 10.0; WOW64; rv:54.0) Gecko/20100101 Firefox/54.0

[bugday-20170222]
I reproduced this bug using Fx 53.0a1, build ID: 20161119030204, on Windows 10 x64.
I can confirm this issue is fixed, I verified using Fx 54.0a2, build ID: 20170314004020, on Windows 10 x64, Mac OS X 10.11 and Ubuntu 14.04 LTS.

Cheers!
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.