Misplaced form input suggestion popup in gtk3 firefox

RESOLVED DUPLICATE of bug 1022241

Status

()

Core
Widget: Gtk
RESOLVED DUPLICATE of bug 1022241
a year ago
a year ago

People

(Reporter: alex, Unassigned)

Tracking

50 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8822961 [details]
screenshot.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20161208153507

Steps to reproduce:

- Visit a site with a login form, where you have at least one saved login
- If its only one login, empty username and password field
- click the username field, then click it again

example sites where i can reproduce 100%: django admin login pages (with django default css).


Actual results:

- menu with username suggestion should open right below the username field


Expected results:

- menu opens quite a bit below the username field
- mouse motions control the list with the offset as it has (you can hover one of the items, with having the mouse at the offset)
- clicking when you selected the field this way does NOT select the item
- you CANNOT select the item by moving the cursor to it an click it
- you CAN select an item by using the keyboard (up/down/enter or right-arrowkey)
(Reporter)

Updated

a year ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Version: 49 Branch → 50 Branch

Updated

a year ago
Component: Untriaged → Widget: Gtk
Product: Firefox → Core
Is this a dupe of bug 1325589?
Flags: needinfo?(allo)
(Reporter)

Comment 2

a year ago
I am not sure.

I did not observe a pure horizontal offset and it isn't at all bound to other controls in the page. I am not sure about the orange square in the screenshot from #1325589. But it surely is a good idea to look at both cases when debugging the issue.
Maybe you can merge it, but then consider both screenshots for the bug.
Flags: needinfo?(allo)
(Reporter)

Comment 3

a year ago
I currently observed a page, where the behaviour suddenly changed and i now cannot reproduce the buggy behaviour again. On another page it worked after submitting a form.
This is most likely a result of the same underlying bug as bug 1022241.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1022241
You need to log in before you can comment on or make changes to this bug.