Add Search Engine Button Does Not Work

RESOLVED DUPLICATE of bug 1323525

Status

()

Firefox
Search
P1
normal
RESOLVED DUPLICATE of bug 1323525
2 years ago
a year ago

People

(Reporter: davidpost-1, Assigned: adw)

Tracking

({regression})

53 Branch
Firefox 54
x86_64
Linux
regression
Points:
---

Firefox Tracking Flags

(firefox50 unaffected, firefox51 unaffected, firefox52 unaffected, firefox53+ verified, firefox54 verified)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170101030204

Steps to reproduce:

1. Visit a search engine that is not currently installed in firefox.
2. In firefox's search bar, the magnifying glass should have a green "+" symbol. Click the magnifying glass.
3. Click "Add ... " to add the search engine.


Actual results:

The search engine is not added. There appears to be no change to any search preferences.

This problem has been replicated in a clean profile and by others on the nightly IRC.


Expected results:

A new search engine should have been added.
(Reporter)

Updated

2 years ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

Updated

2 years ago
Component: Untriaged → Search

Comment 1

2 years ago
WFM with the latest FF53 on Win 7. Is it specific to Linux?
Could you run mozregression to narrow down a regression range, please.
http://mozilla.github.io/mozregression/
Flags: needinfo?(davidpost-1)
Keywords: regressionwindow-wanted

Comment 2

2 years ago
WFM with build 20170101030204 on Win10, added work on https://www.baidu.com/.
(Reporter)

Comment 3

2 years ago
(In reply to Loic from comment #1)
> WFM with the latest FF53 on Win 7. Is it specific to Linux?
> Could you run mozregression to narrow down a regression range, please.
> http://mozilla.github.io/mozregression/


I haven't tried on windows.
I've run mozregression on linux and the final output is as follows.

29:05.29 INFO: Looks like the following bug has the changes which introduced the regression:
https://bugzilla.mozilla.org/show_bug.cgi?id=1113747

Updated

2 years ago
Blocks: 1113747
status-firefox50: --- → unaffected
status-firefox51: --- → unaffected
status-firefox52: --- → unaffected
status-firefox53: --- → affected
tracking-firefox53: --- → ?
Flags: needinfo?(davidpost-1)
Keywords: regressionwindow-wanted → regression

Comment 4

2 years ago
Same issue here on Linux.
See Also: → bug 1326826
We can track this for 53, but we should also check to see if this bug is a dupe of one of the other bugs on file - Bug 1323525 for example is very similar. It seems as if there are a number of search selections not working in Linux.
tracking-firefox53: ? → +

Updated

2 years ago
See Also: → bug 1325586

Updated

2 years ago
See Also: bug 1325586
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P1
(Assignee)

Updated

2 years ago
Assignee: nobody → adw
Status: NEW → ASSIGNED

Updated

2 years ago
Duplicate of this bug: 1334505
[Regression range]:
 Last good revision: 55a41c5e8e88010ea8a539c009f27b7b14988700
 First bad revision: 3e92691272d3139d0f428bf7499bc65f7318f540
 Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=55a41c5e8e88010ea8a539c009f27b7b14988700&tochange=3e92691272d3139d0f428bf7499bc65f7318f540

 Looks like the following bug has the changes which introduced the regression:
https://bugzilla.mozilla.org/show_bug.cgi?id=1113747

Comment 8

2 years ago
Regression range has been already established in comment #3. ;)
(Assignee)

Comment 9

2 years ago
This is the same problem as bug 1323525 and is fixed by the patch there.
(Assignee)

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Assignee)

Updated

2 years ago
status-firefox54: --- → fixed
Target Milestone: --- → Firefox 54

Comment 10

2 years ago
I have reproduced this bug with Nightly 53.0a1 (2017-01-01) (64-bit) on Manjaro 16 64bit.

Verified as fixed with Latest Nightly 54.0a1

Build ID 	20170202110108
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:54.0) Gecko/20100101 Firefox/54.0
I can confirm comment 10. I will set the flag accordingly.
status-firefox54: fixed → verified
(Assignee)

Comment 12

2 years ago
I'm just going to dupe this to bug 1323525 instead of continuing to copy all the status flags, etc.  They're different bugs but they have exactly the same cause.
Resolution: FIXED → DUPLICATE
Duplicate of bug: 1323525
Fixed in 53 in the duplicate bug.
status-firefox53: affected → fixed
This issue is no longer reproducible. I verified using Fx 52.0b3 on Ubuntu 14.04 LTS x 64.
status-firefox53: fixed → verified

Comment 15

a year ago
I am still able to reproduce this on nightly 2017-03-20 (Linux), the bug 1323525 is fixed for me though.

Comment 16

a year ago
Drew, do we need to reopen this bug?
Flags: needinfo?(adw)
Please file a new bug, this is a new regression in 55. It would be very helpful if we could get a regression window as well.
Flags: needinfo?(adw)
You need to log in before you can comment on or make changes to this bug.