username and password not suggested on imagemagick forum on firefox mobile

RESOLVED DUPLICATE of bug 1461255

Status

()

P3
normal
RESOLVED DUPLICATE of bug 1461255
2 years ago
9 months ago

People

(Reporter: i1092979, Unassigned)

Tracking

50 Branch
Points:
---

Firefox Tracking Flags

(firefox57 affected, firefox58 affected, firefox59 affected, firefox60 affected)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161209093710

Steps to reproduce:

Having your account registered with Firefox on desktop, and having a Sync account, try to login from firefox mobile for android. Username is autofilled but password not:

https://www.imagemagick.org/discourse-server/ucp.php?mode=login
(Reporter)

Updated

2 years ago
Summary: password not suggested on imagemagick forum → username and password not suggested on imagemagick forum on firefox mobile
Version: unspecified → 50 Branch
(Reporter)

Comment 1

2 years ago
version 50.1.0.

Correction: username is not suggested either.
Hello, since this is a Login autofill issue, I will move this report to the Logins, Passwords and Form Fill component. Please move it to the correct component if I am wrong.
Component: General → Logins, Passwords and Form Fill

Comment 3

2 years ago
Hello and thank you for your report. 
I've tested with HTC Desire 820 (Android 6.0.1) & Motorola  XT910 (Android 4.4.4) on Firefox 50.1.0 and on the latest Nightly. Could not reproduce the issue that you described.
After I was logged in on desktop Firefox, I've logged in on my mobile device and synced the devices. Then after disconnecting and logging in again on mobile, the username and password were suggested.
Are these the same steps that you performed?
Flags: needinfo?(i1092979)
(Reporter)

Comment 4

2 years ago
Ok, I've tried again uninstalling Firefox Mobile and reinstalling again. Now when enter the forum, on the username field it suggests dozens of usernames (like suggests all usernames from all websites I'm registered to). Meanwhile, on the desktop version of firefox it only suggests the appropriate username for the site, not all of them.

Comment 5

2 years ago
Re-checked the first issue posted and I've managed to see how the username and passwords are not auto-filled, but only after you clean the browser's history & data. After a new sync, the logins should be brought back from your synced devices, but it's not happening. 
As a workaround: the saved logins are restored if you clear data for the app, from the device's Settings menu> Apps> Firefox> Clear Data, and then sign in again with your sync account.

The second issue, other usernames suggestions than the ones for that particular site, I was not able to reproduce.

I will continue to investigate this issue further.
I was able to reproduce this on Xiaomi Mi Pad 2 (Android 5.1 x86). After the sync is performed, the password is not auto-filled. This is reproducible also if I open the page in different tab after I saved the password.

Note: only reproducible on x86 device.
Status: UNCONFIRMED → NEW
tracking-fennec: --- → ?
status-firefox57: --- → affected
status-firefox58: --- → affected
Ever confirmed: true
tracking-fennec: ? → ---
Priority: -- → P3
status-firefox59: --- → affected
Reproducible also when performing a sync with Google Pixel (Android 8.0), HTC 10 (Android 7.0) and Win 10.
status-firefox60: --- → affected
See Also: → bug 1461255
Thanks! I suspect this is a direct dupe of bug 1461255. What we need to fix this is:

* On desktop, install the about-sync addon from AMO and verify the password you are testing is shown on the server. This rules out a desktop bug uploading it.

* Follow http://160.twinql.com/how-to-file-a-good-android-sync-bug to try and get log output from Android and attach it to a bug.
Closing this as a duplicate of Bug 1461255.
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Flags: needinfo?(i1092979)
Resolution: --- → DUPLICATE
Duplicate of bug: 1461255
You need to log in before you can comment on or make changes to this bug.