Closed Bug 1328204 Opened 4 years ago Closed 4 years ago

"Save Page" doesn't save web fonts used in the page nor rewrites its url

Categories

(Firefox :: File Handling, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 115107

People

(Reporter: xidorn, Unassigned)

Details

Attachments

(1 file)

Attached file testcase
Steps to reproduce:
1. Open the testcase attached
2. Save this page (via File / Save Page As, or Ctrl-S)
3. Open the saved page

Expected result:
The page shows a black block as how it is shown when opened directly.

Actual result:
The page shows "XXX" instead.


This is because the page uses a web font, and the web font is specified via a relative path. The page saver doesn't download the web font, nor rewrite the url of the font to the original location, thus this issue.

I think the page saver should download the web font at the same time.
This applies to all resources referenced in CSS. https://dxr.mozilla.org/mozilla-central/rev/57ac9f63fc6953f4efeb0cc84a60192d3721251f/embedding/components/webbrowserpersist/WebBrowserPersistLocalDocument.cpp#1178
>            // TODO if "type" attribute == "text/css"
>            //        fixup stylesheet
Status: NEW → RESOLVED
Closed: 4 years ago
Component: Untriaged → File Handling
Resolution: --- → DUPLICATE
Duplicate of bug: 115107
You need to log in before you can comment on or make changes to this bug.