Do not use binding_details things in AudioContext, use Sequence instead

RESOLVED FIXED in Firefox 53

Status

()

defect
P2
normal
Rank:
21
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: edgar, Assigned: edgar)

Tracking

unspecified
mozilla53
Points:
---

Firefox Tracking Flags

(firefox53 fixed)

Details

Attachments

(1 attachment)

Assignee

Description

3 years ago
Codes under binding_detail namespace are binding internal structure. In AudioContext case, we could use Sequence instead.
Assignee

Comment 1

3 years ago
Posted patch Patch, v1Splinter Review
Assignee

Comment 2

3 years ago
Comment on attachment 8823167 [details] [diff] [review]
Patch, v1

Review of attachment 8823167 [details] [diff] [review]:
-----------------------------------------------------------------

Hi Dan, could you help to review this? Thank you.
Attachment #8823167 - Flags: review?(dminor)
Heh, I have the same patch up for review at Bug 1328144 :) I'll dup my bug to this one and review here.

Updated

3 years ago
Duplicate of this bug: 1328144
Comment on attachment 8823167 [details] [diff] [review]
Patch, v1

Review of attachment 8823167 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM
Attachment #8823167 - Flags: review?(dminor) → review+

Comment 8

3 years ago
Pushed by echen@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/372eaedb265d
Do not use binding_detail things in AudioContext, use Sequence instead; r=dminor
Rank: 21
Priority: -- → P2

Comment 9

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/372eaedb265d
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
You need to log in before you can comment on or make changes to this bug.