Closed Bug 1328245 Opened 4 years ago Closed 4 years ago

Should be able to specify the moz-extension scheme URL in the documentUrlPatterns parameter of chrome.contextMenus.create.

Categories

(WebExtensions :: Untriaged, defect)

52 Branch
x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1271354

People

(Reporter: mitsugu.oyama, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161208153507

Steps to reproduce:

Execute the following code with background scirpt.

[code]
  function createContextMenu(){
    var parentId= chrome.contextMenus.create({
      "title":"Test",
      "type":"normal",
      "contexts":["all"],
      "documentUrlPatterns":[chrome.extension.getURL("popup/main.html")]
    });
[/code]


Actual results:

Context menu is not displayed.


Expected results:

The context menu should be displayed only on main.html.Google Chrome will behave like that.
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Version: 50 Branch → 52 Branch
Component: Untriaged → WebExtensions: Untriaged
Product: Firefox → Toolkit
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1271354
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.