Closed Bug 1328252 Opened 5 years ago Closed 5 years ago

Always unbox NewArray/NewObject cached optimizations.

Categories

(Core :: JavaScript Engine: JIT, defect, P1)

defect

Tracking

()

RESOLVED FIXED
mozilla53
Tracking Status
firefox53 --- fixed

People

(Reporter: h4writer, Assigned: h4writer)

References

Details

Attachments

(1 file)

When adding the NewArray/NewObject shared stub I seemed to have forgotten to always unbox them to MIRType::Object. Time to fix that.
Attached patch PatchSplinter Review
Assignee: nobody → hv1989
Attachment #8823237 - Flags: review?(jdemooij)
Attachment #8823237 - Flags: review?(jdemooij) → review+
Priority: -- → P1
Pushed by hv1989@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/3fcd33279ff2
IonMonkey: Always unbox NewArray/NewObject cached optimizations, r=jandem
https://hg.mozilla.org/mozilla-central/rev/3fcd33279ff2
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Duplicate of this bug: 1328132
You need to log in before you can comment on or make changes to this bug.