crash delete selected text in compose window [@ nsLineLayout::IsPercentageUnitSides]

VERIFIED FIXED

Status

()

Core
Layout
--
critical
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: Scott MacGregor, Assigned: Marc Attinasi)

Tracking

({crash})

Trunk
x86
Windows 2000
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

16 years ago
I was replying to a message someone had sent me. Someone had sent me the
following web page:
http://news.com.com/2100-1023-866659.html

In the compose window, I selected all of the text in the message and hit delete. 

That's when I crashed here,  Incident ID 4353937
Build ID: 2002031805

nsLineLayout::IsPercentageUnitSides
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsLineLayout.cpp, line 1761]
IsPercentageAwareChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 1139]
nsBlockFrame::ReflowInlineFrame
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3687]
nsBlockFrame::DoReflowInlineFrames
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3576]
nsBlockFrame::DoReflowInlineFramesAuto
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3501]
nsBlockFrame::ReflowInlineFrames
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3446]
nsBlockFrame::ReflowLine
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2612]
nsBlockFrame::ReflowDirtyLines
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2251]
nsBlockFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 846]
nsBlockReflowContext::DoReflowBlock
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockReflowContext.cpp, line
581]
nsBlockReflowContext::ReflowBlock
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockReflowContext.cpp, line
359]
nsBlockFrame::ReflowBlockFrame
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3202]
nsBlockFrame::ReflowLine
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2478]
nsBlockFrame::ReflowDirtyLines
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2251]
nsBlockFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 846]
nsBlockReflowContext::DoReflowBlock
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockReflowContext.cpp, line
581]
nsBlockReflowContext::ReflowBlock
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockReflowContext.cpp, line
359]
nsBlockFrame::ReflowBlockFrame
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3202]
nsBlockFrame::ReflowLine
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2478]
nsBlockFrame::ReflowDirtyLines
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2251]
nsBlockFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 846]
nsContainerFrame::ReflowChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 805]
C
(Reporter)

Comment 1

16 years ago
filling in the rest of the subject. 
Keywords: crash, nsbeta1
Summary: crash [@ nsLineLayout::IsPercentageUnitSides] → crash delete selected text in compose window [@ nsLineLayout::IsPercentageUnitSides]

Updated

16 years ago
Severity: normal → critical
Status: NEW → ASSIGNED
(Assignee)

Comment 2

16 years ago
I cannot duplicate this with today's CVS build. I'll look at the code and see if
there is anything obvious though.

Comment 3

16 years ago
Changing QA contact
QA Contact: petersen → amar
nsbeta1-. Can not reproduce.

Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Keywords: nsbeta1 → nsbeta1-
Priority: -- → P2
Resolution: --- → FIXED
Target Milestone: --- → Future
(Assignee)

Comment 5

16 years ago
The latest talkback was on 3/25 - probably has been fixed by now since they were
coming in somewhat regularly (according to talkback anyway)
Keywords: nsbeta1- → nsbeta1
Priority: P2 → --
Target Milestone: Future → ---

Comment 6

16 years ago
 Couldnt reporduce it. Marking verified-Fixed..
Status: RESOLVED → VERIFIED
Crash Signature: [@ nsLineLayout::IsPercentageUnitSides]
You need to log in before you can comment on or make changes to this bug.