Closed Bug 1328559 Opened 3 years ago Closed 3 years ago

WebGL2 Draw samples are not displayed

Categories

(Core :: Canvas: WebGL, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
mozilla53
Tracking Status
firefox50 --- unaffected
firefox51 --- verified
firefox52 --- verified
firefox53 --- verified

People

(Reporter: mboldan, Assigned: jgilbert)

References

Details

(Whiteboard: gfx-noted)

Attachments

(1 file, 1 obsolete file)

[Affected versions]:
- Firefox 50.1.0, Firefox 51.0b11, Firefox 52.0a2 (2017-01-03), Firefox 53.0a1 (2017-01-03) 
 
[Affected platforms]:
- Windows 8.1x64, Mac OS X 10.11, Ubuntu 16.04x64

[Steps to reproduce]:
1. Launch Firefox.
2. Go to http://webglsamples.org/WebGL2Samples/.
3. Click on the first two options from Draw section (draw_image_space and draw_instanced).

[Expected result]:
- Both samples are correctly displayed.

[Actual result]:
- A black page is displayed.

[Regression range]:
- This is a recent regression. Here is the result from mozregression:
Last good revision: 0de5f500516b0d576fd77f342ac2570b536e8115
First bad revision: c274a7c25dc7e3a9228b3b9a5c1917e985ff4192
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=0de5f500516b0d576fd77f342ac2570b536e8115&tochange=c274a7c25dc7e3a9228b3b9a5c1917e985ff4192

[Additional notes]:
- Note that the third sample from Draw section (draw_primitive_restart) was not working on the previous builds and on the latest builds the sample is correctly displayed.
QA Whiteboard: [qe-webgl2]
Whiteboard: gfx-noted
Updating the 'Affected platform' list:
- Windows 8.1x64, Mac OS X 10.11

The issue is not reproducible on Ubuntu OSs.
Since WebGL2 is not implemented in Firefox 50, it's expected for the samples to not be displayed on this specific build.
I'm removing the affected flag for status-firefox50.
I'd rather seeing this as an WebGL2 implementation bug than a regression bug since Firefox 51 is the first version supporting WebGL2. Let's keep the trace on bug webgl2-blockers.
Keywords: regression
We're validating active built-in attrib types, which it seems clear we shouldn't be.
Assignee: nobody → jgilbert
Comment on attachment 8823846 [details]
Bug 1328559 - (flattened) Built-in attribs should have location of -1. -

https://reviewboard.mozilla.org/r/102328/#review102750
Attachment #8823846 - Flags: review?(dmu) → review+
ANGLE is returning >=0 for glGetAttribLocation(prog, "gl_VertexID") when it's active.
The spec is not clear on this, but at least GL on Win+Intel yield -1 for this.
It makes the most sense for this to require that this is -1. Chrome also seems to match this behavior.
Pushed by jgilbert@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/cdd2a4506727
(flattened) - Built-in attribs should have location of -1. - r=daoshengmu
(In reply to Mihai Boldan, QA [:mboldan] from comment #1)
> Updating the 'Affected platform' list:
> - Windows 8.1x64, Mac OS X 10.11
> 
> The issue is not reproducible on Ubuntu OSs.

Which OSX GPU vendor is it reproducible on?
Which Linux GPU vendor is it not reproducing on?
Flags: needinfo?(mihai.boldan)
I see this reproducing on:
* Win+Any+ANGLE
* Mac+NV

Working fine on:
* Win+NV+GL
FWIW I also can't reproduce on Linux nightly, renderer is "Intel Open Source Technology Center -- Mesa DRI Intel(R) HD Graphics 520 (Skylake GT2)"
Sorry, I have it working fine on Win+Intel+GL. Win+NV+GL is unknown.

I also have it working fine on Win+AMD+GL.
I also see it broken Mac+Intel.
Attachment #8823985 - Attachment is obsolete: true
(In reply to Jeff Gilbert [:jgilbert] from comment #12)
> (In reply to Mihai Boldan, QA [:mboldan] from comment #1)
> > Updating the 'Affected platform' list:
> > - Windows 8.1x64, Mac OS X 10.11
> > 
> > The issue is not reproducible on Ubuntu OSs.
> 
> Which OSX GPU vendor is it reproducible on?
> Which Linux GPU vendor is it not reproducing on?

The tests on Windows an Ubuntu were performed on the same PC - GPU - AMD Radeon HD 6450
And for Mac OS X - GPU - Intel Iris Pro 1536 MB

Please let me know if I can provide you any other information.
Flags: needinfo?(mihai.boldan)
https://hg.mozilla.org/mozilla-central/rev/cdd2a4506727
https://hg.mozilla.org/mozilla-central/rev/3b469ed8f819
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Comment on attachment 8823846 [details]
Bug 1328559 - (flattened) Built-in attribs should have location of -1. -

Approval Request Comment
[Feature/Bug causing the regression]: webgl2 regression common to content
[User impact if declined]: webgl2 content won't work
[Is this code covered by automated tests?]: tests included with patch, and upstreamed.
[Has the fix been verified in Nightly?]:
[Needs manual test from QE? If yes, steps to reproduce]: 
[List of other uplifts needed for the feature/fix]:
[Is the change risky?]: no
[Why is the change risky/not risky?]: Simple fix, with tests.
[String changes made/needed]:
Attachment #8823846 - Flags: approval-mozilla-beta?
Attachment #8823846 - Flags: approval-mozilla-aurora?
Comment on attachment 8823846 [details]
Bug 1328559 - (flattened) Built-in attribs should have location of -1. -

webgl2 fix for aurora52 and beta51, should be in 51.0b13
Attachment #8823846 - Flags: approval-mozilla-beta?
Attachment #8823846 - Flags: approval-mozilla-beta+
Attachment #8823846 - Flags: approval-mozilla-aurora?
Attachment #8823846 - Flags: approval-mozilla-aurora+
Flags: qe-verify+
The issue is no longer reproducible on Firefox 51.0b13(tinderbox build), Firefox 52.0a2 (2017-01-09), or on Firefox 53.0a1 (2017-01-09).
The tests were performed under Windows 10x64, Mac OS X 10.11 and under Ubuntu 16.04x64.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.