Closed Bug 1328662 Opened 3 years ago Closed 3 years ago

Unable to join WebEx meeting in Firefox Developer Edition

Categories

(Web Compatibility :: Desktop, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: kwilson, Assigned: kwilson)

References

Details

(Whiteboard: [sitewait])

Attachments

(3 files)

I was unable to login to my WebEx meeting via Firefox this morning, so had to switch to another browser. :-(

Here's what happened:
https://pageshot.net/uecQfwzGXcngPRf9/meetings.webex.com

It says:
"Step 1 of 2: Add WebEx to Chrome
Follow this one-time process to join WebEx meetings quickly in the future."
and has an "Add WebEx to Chrome" button

I don't have Chrome installed on my desktop system, and clicking the button doesn't appear to do anything.

I'm currently running Firefox Developer Edition 52.0a2 (2016-12-19) (64-bit) on OS X El Capitan Version 10.11.6.
In principle this is an evangelism issue, so I'm moving it there.

Andy, do we have plans of making add-on install for Chrome work automatically if we detect that it could, or something?

(not sure if that would be the case here, but I figured I'd ask.)

Kathleen, do you have a link to reproduce? Can anyone sign up for a webex account in order to reproduce, or...?
Component: General → Desktop
Flags: needinfo?(kwilson)
Flags: needinfo?(amckay)
Product: Firefox → Tech Evangelism
(In reply to :Gijs from comment #1)
> Kathleen, do you have a link to reproduce? Can anyone sign up for a webex
> account in order to reproduce, or...?

I don't have my own WebEx account, but it looks like you can get one for free:
https://www.webex.com/

I was just trying to join a meeting that someone else had set up.
Flags: needinfo?(kwilson)
(In reply to :Gijs from comment #1)
> In principle this is an evangelism issue, so I'm moving it there.
> 
> Andy, do we have plans of making add-on install for Chrome work
> automatically if we detect that it could, or something?

Haven't planned that, this button would point to a Chrome packaged extension that would be signed using Googles key not ours. Currently we have no plans to accept Chrome signed extensions.
Flags: needinfo?(amckay)
I created an account. It looks like the user agent detection on the Webex site might be broken. If I use Firefox 50/51 (or spoof user agent in Nightly) the page to download the Webex appears. After installing, the meeting starts as expected.

Using Firefox 52/53 when I try to join the meeting, it takes me to the "Add WebEx to Chrome" screen. As I mentioned spoofing the UA here makes it work like Firefox 50.
Attached image Firefox 50
Attached image Firefox 52
If the WebEx site works on Firefox 50/51 and no longer works on Firefox 52/53, then it seems to me that there is breaking change / compatibility change in Firefox.
(In reply to Kathleen Wilson from comment #7)
> If the WebEx site works on Firefox 50/51 and no longer works on Firefox
> 52/53, then it seems to me that there is breaking change / compatibility
> change in Firefox.

The only difference with newer versions is the "user agent" string that Firefox sends. It looks like the website for some reason thinks that the newer user agent string indicates you're using Chrome. You can use an add-on or modify an internal preference in Firefox to change the user agent string. Comment 10 suggests that using the Firefox 50/51 user agent string with Nightly makes it work just fine. So this is a problem in how the website is detecting Firefox - it's normal that we change the version number in the user agent string.

If we have a contact at WebEx we can prod them about it - it could be as simple as them having to update some kind of user agent database that they use (cf. WURFL and friends).
Maire, I'm told you might know folks who work on webex and/or at cisco who we could ask about this? :-)
Flags: needinfo?(mreavy)
Yes, I'm the right person, Gijs :-)

Paul -- Can you look into this for us?
Flags: needinfo?(mreavy) → needinfo?(paulej)
Investigating.
Flags: needinfo?(paulej)
I was able to confirm this is an issue with meetings.webex.com.  Engineers are now looking into why it is happening.
The engineers responsible for maintaining this code on meetings.webex.com were able to reproduce the issue and are working on a solution.  Not ETA at this time, but they are working on it.
Still having to use a different browser for the weekly WebEx meeting I have to join. :-(
See Also: → 1346815
Paul - Wondering if you have heard anything back from Cisco regarding Firefox support? Curious what their plans are moving forward. Thanks!

We are seeing other issues with WebEx in Windows as well (bug 1346815).
Flags: needinfo?(paulej)
Yes, I did.  I had been communicating with Kathleen privately about this.  A fix is coming soon, but I was asked not to commit to a specific date.  They do have a target date around the corner, though.  I will update this bug as soon I've notified that the fix went into production.
Flags: needinfo?(paulej)
I'm able to join WebEx via Firefox now!
One-time install - screen shot attached.
Assignee: nobody → kwilson
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
That's great, thanks for the update Kathleen (and thanks to WebEx folks)!
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.