Closed Bug 13287 Opened 21 years ago Closed 21 years ago

MLK: nsComponentManager::PlatformPrePopulateRegistry()

Categories

(Core :: XPCOM, defect, P3)

defect

Tracking

()

VERIFIED DUPLICATE of bug 13286

People

(Reporter: bruce, Assigned: shaver)

Details

This one has an easy fix!

[W] MLK: Memory leak of 6073 bytes from 376 blocks allocated in PL_strdup
        Distribution of leaked blocks
              2601 bytes from 153 blocks of 17 bytes (first block: 0x035857f0)
allocation number 553
              1296 bytes from 81 blocks of 16 bytes (first block: 0x02bdc300)
allocation number 3794
               728 bytes from 52 blocks of 14 bytes (first block: 0x02bdc118)
allocation number 3774
               532 bytes from 28 blocks of 19 bytes (first block: 0x035f8320)
allocation number 2193
               288 bytes from 24 blocks of 12 bytes (first block: 0x035fa490)
allocation number 2223
               270 bytes from 18 blocks of 15 bytes (first block: 0x035814c8)
allocation number 3844
               117 bytes from 9 blocks of 13 bytes (first block: 0x0361db60)
allocation number 2724
               104 bytes from 4 blocks of 26 bytes (first block: 0x03584348)
allocation number 3884
                60 bytes from 3 blocks of 20 bytes (first block: 0x035f6cc8)
allocation number 2173
                54 bytes from 3 blocks of 18 bytes (first block: 0x02bdfbd8)
allocation number 3824
                23 bytes from 1 block of 23 bytes (0x03628e10) allocation number
2884
        Allocation location
            malloc         [dbgheap.c:129]
            PL_strdup      [strdup.c:30]
            nsComponentManagerImpl::PlatformPrePopulateRegistry(void)
[nsComponentManager.cpp:783]
            NS_InitXPCOM(nsIServiceManager * *) [nsXPComInit.cpp:394]
            main           [nsAppRunner.cpp:855]
            mainCRTStartup [crtexe.c:338]

This one looks like it is the PL_strdup()'d value being passed to the
FactoryEntry constructor.  That constructor already strdup's this value so you
don't have to!
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
doh, this is the same as the last one i filed.  I'm an idiot.

*** This bug has been marked as a duplicate of 13286 ***
Status: RESOLVED → VERIFIED
easy verify.  duplicate of 13286
You need to log in before you can comment on or make changes to this bug.