Console message gets logged every time, not only after overrides

VERIFIED FIXED

Status

VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: denschub, Assigned: denschub)

Tracking

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
The message "The user agent has been overridden for compatibility reasons." shows up every time, not only if an user agent override was in place.
(Assignee)

Comment 1

2 years ago
Created attachment 8824042 [details] [review]
Pull request to fix this issue, Version 1

Using `getUAForURI` is not the best idea, since it will return an UA string regardless if we need to override it or not. Therefore, I've implemented `hasUAForURIInCache` do actually check if we need to override the current URI or not.
Attachment #8824042 - Flags: review?(etsai)
Comment on attachment 8824042 [details] [review]
Pull request to fix this issue, Version 1

Looks good for me to use hasUAForURIInCache for check override only
Attachment #8824042 - Flags: review?(etsai) → review+
(Assignee)

Comment 3

2 years ago
Thanks, merged.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED

Comment 4

2 years ago
Tested on Mac OS X 10.10, 10.12, Ubuntu 16.04 x64 and Windows 10 x64 with Firefox Nighlty 53.0a1(2016-01-05) ussing the .xpi with the fix received from Dennis and I can confirm the fix.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.