Closed Bug 1328867 Opened 9 years ago Closed 8 years ago

puppet fails admin2a.private.yvr1

Categories

(Infrastructure & Operations :: Infrastructure: Other, task)

task
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Usul, Assigned: ashish)

Details

Info: Applying configuration version '8d0def68ee9e7a9a40ca62a19fd94ab45974bb78' Info: FileBucket got a duplicate file {md5}b8af860e8902f003ed6bf9d6bdc137d5 Info: /Stage[main]/Iproute/File[/usr/local/bin/puppet-iprule]: Filebucketed /usr/local/bin/puppet-iprule to main with sum b8af860e8902f003ed6bf9d6bdc137d5 Error: Operation not permitted - (/usr/local/bin/puppet-iprule20170105-18767-18akz35, /usr/local/bin/puppet-iprule) Error: /Stage[main]/Iproute/File[/usr/local/bin/puppet-iprule]/content: change from {md5}b8af860e8902f003ed6bf9d6bdc137d5 to {md5}056caf062f3406f0f7e24d7312bfe9f0 failed: Operation not permitted - (/usr/local/bin/puppet-iprule20170105-18767-18akz35, /usr/local/bin/puppet-iprule) Info: FileBucket got a duplicate file {md5}40d9ea3bb27b1a47a09674be72b2f0e3 Info: /Stage[main]/Iproute/File[/usr/local/bin/puppet-iproute]: Filebucketed /usr/local/bin/puppet-iproute to main with sum 40d9ea3bb27b1a47a09674be72b2f0e3 Error: Operation not permitted - (/usr/local/bin/puppet-iproute20170105-18767-d0c3jp, /usr/local/bin/puppet-iproute) Error: /Stage[main]/Iproute/File[/usr/local/bin/puppet-iproute]/content: change from {md5}40d9ea3bb27b1a47a09674be72b2f0e3 to {md5}49126e9e5ac893cfe5a3c11fcc9667d5 failed: Operation not permitted - (/usr/local/bin/puppet-iproute20170105-18767-d0c3jp, /usr/local/bin/puppet-iproute) Notice: /Stage[main]/Iproute/Tools::Line[install-routes]/Exec[add_line /usr/local/bin/puppet-iproute /etc/rc.local]: Dependency File[/usr/local/bin/puppet-iproute] has failures: true Warning: /Stage[main]/Iproute/Tools::Line[install-routes]/Exec[add_line /usr/local/bin/puppet-iproute /etc/rc.local]: Skipping because of failed dependencies Notice: /Stage[main]/Iproute/Tools::Line[install-rules]/Exec[add_line /usr/local/bin/puppet-iprule /etc/rc.local]: Dependency File[/usr/local/bin/puppet-iprule] has failures: true Warning: /Stage[main]/Iproute/Tools::Line[install-rules]/Exec[add_line /usr/local/bin/puppet-iprule /etc/rc.local]: Skipping because of failed dependencies Notice: /Stage[main]/Main/Node[admin2a.private.yvr1.mozilla.com]/Iproute::Sticky_interface[201]/Exec[/usr/local/bin/puppet-iprule rule-sticky-201]: Dependency File[/usr/local/bin/puppet-iprule] has failures: true Warning: /Stage[main]/Main/Node[admin2a.private.yvr1.mozilla.com]/Iproute::Sticky_interface[201]/Exec[/usr/local/bin/puppet-iprule rule-sticky-201]: Skipping because of failed dependencies Notice: /Stage[main]/Main/Node[admin2a.private.yvr1.mozilla.com]/Iproute::Sticky_interface[201]/Exec[/usr/local/bin/puppet-iproute route-sticky-201]: Dependency File[/usr/local/bin/puppet-iproute] has failures: true Warning: /Stage[main]/Main/Node[admin2a.private.yvr1.mozilla.com]/Iproute::Sticky_interface[201]/Exec[/usr/local/bin/puppet-iproute route-sticky-201]: Skipping because of failed dependencies Notice: Finished catalog run in 69.60 seconds
Summary: puppetctl fails admin2a.private.yvr1 → puppet fails admin2a.private.yvr1
fails on admin2a on sfo too for the same reason it seems.
:ashish, seems related to 1298941. can we puppetize the fix?
Flags: needinfo?(ashish)
I discussed the underlying problem with Netops. I believe we should be able to get rid of IP routes on offices that have their network gear up-to-date. I'll test this by removing the routes in some of the offices to confirm.
This has been fixed.
Assignee: infra → ashish
Status: NEW → RESOLVED
Closed: 8 years ago
Flags: needinfo?(ashish)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.