Land late string change for about:tabcrashed

RESOLVED FIXED in Firefox 52

Status

()

defect
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: mconley, Assigned: mconley)

Tracking

unspecified
Firefox 53
Points:
---

Firefox Tracking Flags

(firefox52 fixed, firefox53 fixed)

Details

Attachments

(1 attachment)

In bug 1309316, we noticed that one of the strings that we landed was incorrect, and is potentially confusing. See bug 1309316 comment 42 and onwards, in particular.

In bug 1309316 comment 45, flod suggested we attempt to land the corrected string and hope a late string change can be properly translated. This bug is to track that work.
Comment hidden (mozreview-request)
Assignee: nobody → mconley

Comment 2

2 years ago
mozreview-review
Comment on attachment 8824097 [details]
Bug 1328907 - Correct a string in about:tabcrashed.

https://reviewboard.mozilla.org/r/102646/#review102976

Looks good, thanks.
Attachment #8824097 - Flags: review?(francesco.lodolo) → review+

Comment 3

2 years ago
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/58396ef7d409
Correct a string in about:tabcrashed. r=flod
Comment on attachment 8824097 [details]
Bug 1328907 - Correct a string in about:tabcrashed.

Approval Request Comment
[Feature/Bug causing the regression]:

Bug 1309316

[User impact if declined]:

A string will appear in about:tabcrashed that isn't as clear as it should be.

[Is this code covered by automated tests?]:

about:tabcrashed definitely is.

[Has the fix been verified in Nightly?]:

Not yet, but it just autolanded.

[Needs manual test from QE? If yes, steps to reproduce]: 

No.

[List of other uplifts needed for the feature/fix]:

None.

[Is the change risky?]:

No, except for localizers, since this is a late string landing - but flod is aware.

[Why is the change risky/not risky?]:

See above.

[String changes made/needed]:

This is a string change. flod is aware.
Attachment #8824097 - Flags: approval-mozilla-aurora?

Comment 5

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/58396ef7d409
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 53
Comment on attachment 8824097 [details]
Bug 1328907 - Correct a string in about:tabcrashed.

fix a string in about:tabcrashed, l10n-acked, aurora52+
Attachment #8824097 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Thanks KWiesro / jcristau / aryx. Anything else I need to do here, flod?
Flags: needinfo?(francesco.lodolo)
No, everything landed, dashboard is showing the missing string, message sent.
https://groups.google.com/d/msg/mozilla.dev.l10n/zGU5cb_8wzo/26ka-SdVEwAJ
Flags: needinfo?(francesco.lodolo)
You need to log in before you can comment on or make changes to this bug.