disable linux32-debug devtools tests on all branches (trunk, aurora, beta, release, etc.)

RESOLVED FIXED

Status

Release Engineering
General Automation
RESOLVED FIXED
4 months ago
20 days ago

People

(Reporter: jmaher, Assigned: jmaher)

Tracking

(Blocks: 9 bugs, {leave-open})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [stockwell disabled])

Attachments

(4 attachments, 1 obsolete attachment)

(Assignee)

Description

4 months ago
in addition there is some cleanup we might be able to do on ash for linux scheduled buildbot reftests.
Blocks: 1320942
Blocks: 1317053
Blocks: 1273879

Comment 1

4 months ago
Created attachment 8824115 [details] [diff] [review]
do not run mochitest-dt on taskcluster linux32/debug

Since we're just starting to run linux32 tests in taskcluster, here are the changes for taskcluster too.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=3fdbf52227d27e7a65ea41ce6008d563fc7000e0
Attachment #8824115 - Flags: review?(jmaher)
(Assignee)

Comment 2

4 months ago
Comment on attachment 8824115 [details] [diff] [review]
do not run mochitest-dt on taskcluster linux32/debug

Review of attachment 8824115 [details] [diff] [review]:
-----------------------------------------------------------------

great!
Attachment #8824115 - Flags: review?(jmaher) → review+
Blocks: 1328926
(Assignee)

Comment 3

4 months ago
Created attachment 8824135 [details] [diff] [review]
disable linux32 debug devtools and linux* on ash
Assignee: nobody → jmaher
Status: NEW → ASSIGNED
Attachment #8824135 - Flags: review?(bugspam.Callek)
(Assignee)

Comment 4

4 months ago
Created attachment 8824137 [details]
buildbot differences for the related patch
Attachment #8824137 - Flags: feedback?(ryanvm)
Comment on attachment 8824137 [details]
buildbot differences for the related patch

+1!
Attachment #8824137 - Flags: feedback?(ryanvm) → feedback+
Comment on attachment 8824135 [details] [diff] [review]
disable linux32 debug devtools and linux* on ash

This is going to be really pedantic, but can you please keep the suites alphabetized where you're adding MOCHITEST_DT_8 in?

Comment 7

4 months ago
Comment on attachment 8824135 [details] [diff] [review]
disable linux32 debug devtools and linux* on ash

Review of attachment 8824135 [details] [diff] [review]:
-----------------------------------------------------------------

I'm going to defer this review to buildduty -- however I tend to agree with RyanVM on the pedantic piece ;-)
Attachment #8824135 - Flags: review?(bugspam.Callek) → review?(aselagea)
(Assignee)

Comment 8

4 months ago
Created attachment 8824148 [details] [diff] [review]
disable linux32 debug devtools and linux* on ash

updated patch to be alphabetical and verified the builder diffs are identical.
Attachment #8824135 - Attachment is obsolete: true
Attachment #8824135 - Flags: review?(aselagea)
Attachment #8824148 - Flags: review?(aselagea)
Comment on attachment 8824148 [details] [diff] [review]
disable linux32 debug devtools and linux* on ash

lgtm!
Attachment #8824148 - Flags: review?(aselagea) → review+
(Assignee)

Comment 10

4 months ago
landed this:
https://hg.mozilla.org/build/buildbot-configs/rev/fb273fd16706d9b57d2fb486db3906f17128addb

will wait for test results to post in #releng and then for a reconfig when it is safe or scheduled.
Blocks: 1286780
Blocks: 1285594
Blocks: 1315426
Blocks: 1267082
Blocks: 1273885

Updated

4 months ago
Keywords: leave-open

Comment 11

4 months ago
Pushed by gbrown@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/4bea6ef3d9de
Do not run mochitest-dt on taskcluster linux32/debug; r=jmaher
(Assignee)

Updated

4 months ago
Blocks: 1249211

Comment 12

4 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/4bea6ef3d9de

Updated

4 months ago
Keywords: leave-open

Updated

4 months ago
Blocks: 1317152
I like a lame duck as well as the next guy, assuming the next guy is criminally insane and the nature of his insanity is related to unspeakable acts committed upon disabled waterfowl.

Linux32 debug devtools tests are now hidden on every tree.
(Assignee)

Comment 14

4 months ago
the remaining work here is tracked in bug 1253312

Comment 15

3 months ago
Pushed by gbrown@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/0de700cdb5b6
Skip linux32/debug devtools tests in clipboard and gpu subsuites; r=me
Created attachment 8827224 [details] [diff] [review]
skip linux32 debug devtools tests in subsuites

As :jmaher noted in https://bugzilla.mozilla.org/show_bug.cgi?id=1319218#c5, some devtools tests were still running - and failing - on linux32/debug in subsuite jobs. This patch skips those tests too.
Attachment #8827224 - Flags: review+

Comment 17

3 months ago
Pushed by gbrown@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/96b9fad20c92
Bustage fix for linux gpu failures
The patch in comment 16 caused the gpu job to fail, like https://queue.taskcluster.net/v1/task/KYdIfoFDT_e9bVer4vUkdA/runs/0/artifacts/public/logs/live_backing.log, presumably because all the tests were skipped on linux32/debug. I enabled one of the tests to get around this. What's a better solution?
Flags: needinfo?(jmaher)

Updated

3 months ago
Keywords: leave-open

Comment 19

3 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/0de700cdb5b6
https://hg.mozilla.org/mozilla-central/rev/96b9fad20c92
(Assignee)

Comment 20

3 months ago
:gbrown, it looks like we are running into a failure where we detect tests to run, then end up skipping all of them and generate an error because no results were found:
[task 2017-01-16T19:47:05.032632Z] 19:47:05     INFO - SUITE-START | Running 4 tests
[task 2017-01-16T19:47:05.033488Z] 19:47:05     INFO - TEST-START | devtools/client/canvasdebugger/test/browser_canvas-actor-test-09.js
[task 2017-01-16T19:47:05.033570Z] 19:47:05     INFO - TEST-SKIP | devtools/client/canvasdebugger/test/browser_canvas-actor-test-09.js | took 1ms
[task 2017-01-16T19:47:05.034208Z] 19:47:05     INFO - TEST-START | devtools/client/canvasdebugger/test/browser_canvas-actor-test-10.js
[task 2017-01-16T19:47:05.034889Z] 19:47:05     INFO - TEST-SKIP | devtools/client/canvasdebugger/test/browser_canvas-actor-test-10.js | took 0ms
[task 2017-01-16T19:47:05.034967Z] 19:47:05     INFO - TEST-START | devtools/client/canvasdebugger/test/browser_canvas-actor-test-11.js
[task 2017-01-16T19:47:05.035627Z] 19:47:05     INFO - TEST-SKIP | devtools/client/canvasdebugger/test/browser_canvas-actor-test-11.js | took 0ms
[task 2017-01-16T19:47:05.035708Z] 19:47:05     INFO - TEST-START | devtools/client/canvasdebugger/test/browser_profiling-webgl.js
[task 2017-01-16T19:47:05.036365Z] 19:47:05     INFO - TEST-SKIP | devtools/client/canvasdebugger/test/browser_profiling-webgl.js | took 0ms
[task 2017-01-16T19:47:05.037048Z] 19:47:05     INFO -  TEST-INFO | checking window state
[task 2017-01-16T19:47:05.037128Z] 19:47:05     INFO -  Browser Chrome Test Summary
[task 2017-01-16T19:47:05.037800Z] 19:47:05     INFO -  	Passed: 0
[task 2017-01-16T19:47:05.037899Z] 19:47:05     INFO -  	Failed: 0
[task 2017-01-16T19:47:05.038576Z] 19:47:05     INFO -  	Todo: 0
[task 2017-01-16T19:47:05.039251Z] 19:47:05     INFO -  	Mode: e10s
[task 2017-01-16T19:47:05.039923Z] 19:47:05     INFO -  *** End BrowserChrome Test Results ***
[task 2017-01-16T19:47:05.040588Z] 19:47:05     INFO - Buffered messages finished
[task 2017-01-16T19:47:05.040661Z] 19:47:05     INFO - SUITE-END | took 0s
[task 2017-01-16T19:47:05.093309Z] 19:47:05    ERROR - Return code: 1
[task 2017-01-16T19:47:05.094527Z] 19:47:05     INFO - TinderboxPrint: mochitest-browser-chrome-gpu<br/>4/0/0
[task 2017-01-16T19:47:05.095102Z] 19:47:05    ERROR - # TBPL FAILURE #


in this case, we should fix the mochitest harness (runtests.py) to look at filtered tests and if there are no tests to run, then ignore the entire directory.
Flags: needinfo?(jmaher)
(Assignee)

Updated

2 months ago
Whiteboard: [stockwell disabled]

Updated

2 months ago
Duplicate of this bug: 1229483
(Assignee)

Updated

20 days ago
Status: ASSIGNED → RESOLVED
Last Resolved: 20 days ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.