"Take a screenshot of entire page" ignores viewport while in Responsive Design Mode

RESOLVED WONTFIX

Status

()

Firefox
Developer Tools: Responsive Design Mode
RESOLVED WONTFIX
a year ago
a year ago

People

(Reporter: André Jaenisch, Unassigned)

Tracking

50 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161217201323

Steps to reproduce:

1.) Open Developer Tools
2.) Click the cog to open settings pane.
3.) Enable “Responsive Design Mode” and “Take a screenshot of the entire page” in “Available Toolbox Buttons”.
4.) Active Responsive Design Mode.
5.) Click the camera in Responsive Design Mode UI and in Toolbox Buttons.


Actual results:

Responsive Design Mode UI's camera takes a screenshot of the current viewport whereas the camera of the Toolbox ignores viewport limitations.


Expected results:

I would expect both screenshot to respect the viewport.
(Reporter)

Updated

a year ago
Component: Untriaged → Developer Tools: Responsive Design Mode
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
(Reporter)

Comment 1

a year ago
Created attachment 8824183 [details]
Screenshot taken in RDM
(Reporter)

Comment 2

a year ago
Created attachment 8824184 [details]
Screenshot taken in Toolbox
(Reporter)

Comment 3

a year ago
Maybe I'm confused as the reporter of Bug 1060432 was (UX issue).

I'm unsure whether it is a dupe of Bug 1297641.
At the moment, I am not sure what should be changed here.  I can imagine use cases for both types of screenshots, viewport only and full page.

Each button's tooltip correctly states the type of screenshot it will take.  I agree it's hard to know what to expect sometimes unless you've tried the buttons before, so that part is unfortunate.

I am not convinced that the toolbox screenshot button should change functionality when RDM is opening, as that seems more surprising, not less.

I am marking this won't fix for now, because I don't see a path forward here.  If people have other ideas, let's discuss on Discourse[1] to get a feeling for what would be best.

[1]: https://discourse.mozilla-community.org/c/devtools
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.