Hyper Sensative Syntax Checker

RESOLVED INVALID

Status

()

Core
XML
--
minor
RESOLVED INVALID
16 years ago
15 years ago

People

(Reporter: Daniel Chemko, Assigned: Heikki Toivonen (remove -bugzilla when emailing directly))

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
When trying to view my Shoutcast stream's XML string in Mozilla 0.9.9, I get the
following error:

"
XML Parsing Error: xml processing instruction not at start of external entity
Location: http://localhost:8000/admin.cgi?pass=symbolic&mode=viewxml
Line Number 2, Column 1:
<?xml version="1.0" standalone="yes" ?>
"

In shoutcast, there is a new line character processed before the first
processing instruction. Bad for the shoutcast dev's, but isn't this a little too
strict? I understand having non-whitespace characters throw an error, but this
is a little excessive for my likes.
The XML 1.0 Recommendation defines XML very strictly, and on purpose. An XML
document starts with a prolog which may start with XML declaration. It does not
allow anything before the XML declaration. There are several reasons for that,
for example that makes it easy to detect the encoding of the document because
you only need to look at the first 4 bytes. If we allowed whitespace, it would
be an error.

http://www.w3.org/TR/REC-xml

Marking INVALID.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID

Updated

15 years ago
QA Contact: petersen → rakeshmishra
You need to log in before you can comment on or make changes to this bug.