Port relevant parts of |bug 1323129| to SeaMonkey

RESOLVED FIXED in seamonkey2.50

Status

SeaMonkey
Build Config
RESOLVED FIXED
a year ago
11 months ago

People

(Reporter: ewong, Assigned: frg)

Tracking

SeaMonkey 2.50 Branch
seamonkey2.50

SeaMonkey Tracking Flags

(seamonkey2.50 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Comment hidden (empty)
(Assignee)

Updated

a year ago
Blocks: 1319091
(Assignee)

Comment 1

11 months ago
Created attachment 8824379 [details] [diff] [review]
1329081-webinstaller.patch

I am uneasy about the callback removal but it seems to work.
Assignee: nobody → frgrahl
Status: NEW → ASSIGNED
Attachment #8824379 - Flags: feedback?(philip.chee)

Comment 2

11 months ago
Comment on attachment 8824379 [details] [diff] [review]
1329081-webinstaller.patch

Looks reasonable.
Attachment #8824379 - Flags: feedback?(philip.chee) → feedback+
(Assignee)

Comment 3

11 months ago
Comment on attachment 8824379 [details] [diff] [review]
1329081-webinstaller.patch

Not seeing any other needed changes so this might be it.
Attachment #8824379 - Flags: review?(philip.chee)

Comment 4

11 months ago
Comment on attachment 8824379 [details] [diff] [review]
1329081-webinstaller.patch

r=me a=me
Attachment #8824379 - Flags: review?(philip.chee) → review+

Comment 5

11 months ago
Comment on attachment 8824379 [details] [diff] [review]
1329081-webinstaller.patch

On the other hand we have this:
https://hg.mozilla.org/mozilla-central/rev/d97b2eeffc46#l2.229
Flags: needinfo?(frgrahl)
(Assignee)

Comment 6

11 months ago
Created attachment 8824659 [details] [diff] [review]
1329081-webinstaller-V2.patch

I looked at the code again and you are right. I tested it and canceled an installation but I think because of Bug 1323494 it isn't fully testable right now. But I didn see any errors so I would put it in and do a full retest after the other bug is fixed.
Attachment #8824379 - Attachment is obsolete: true
Flags: needinfo?(frgrahl)
Attachment #8824659 - Flags: review?(philip.chee)

Updated

11 months ago
Duplicate of this bug: 1329423

Comment 8

11 months ago
Comment on attachment 8824659 [details] [diff] [review]
1329081-webinstaller-V2.patch

Cool beans!
r=me a=me
(I don't know what "Cool beans" means but mconley keeps saying that.
Attachment #8824659 - Flags: review?(philip.chee) → review+
(Assignee)

Comment 9

11 months ago
https://hg.mozilla.org/comm-central/rev/a614f645d43da4c018f7f6385c561e4b3324c65f
Status: ASSIGNED → RESOLVED
Last Resolved: 11 months ago
status-seamonkey2.50: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.50
Version: unspecified → SeaMonkey 2.50 Branch
You need to log in before you can comment on or make changes to this bug.