padding styles don't inherit to TD from TR

RESOLVED DUPLICATE of bug 132915

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 132915
16 years ago
16 years ago

People

(Reporter: Erik Talvola, Assigned: Marc Attinasi)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
(forgive me if this is a duplicate - I tried to use the Bugzilla wizard, but it 
looked like it aborted)

Using Mozilla build 2002031104, the following HTML:

<HTML>
<HEAD>
<TITLE>CSS test</TITLE>
</HEAD>
<BODY>

<TABLE CELLPADDING=0>
  <TBODY>
    <TR STYLE="padding-bottom: 88px; padding-top: 88px; font-size: 30pt">
      <TD>
        Home
      </TD>
    </TR>
    <TR STYLE="padding-bottom: 88px; padding-top: 88px">
      <TD>
        Sales
      </TD>
    </TR>
  </TBODY>
</TABLE>
</BODY>
</HTML>

doesn't display the same way it does in IE6.  In IE6, it behaves as expected - 
all of the style values (padding-top, padding-bottom, font-size) are inherited 
by the TD tag, so Home displays in large text, with 88 pixels of padding on 
either side.  In Mozilla, the font size is large, but there is no padding.

If I move the padding values to the TD tag, as follows:

<HTML>
<HEAD>
<TITLE>CSS test</TITLE>
</HEAD>
<BODY>

<TABLE CELLPADDING=0>
  <TBODY>
    <TR>
      <TD STYLE="padding-bottom: 88px; padding-top: 88px">
        Home
      </TD>
    </TR>
    <TR>
      <TD STYLE="padding-bottom: 88px; padding-top: 88px">
        Sales
      </TD>
    </TR>
  </TBODY>
</TABLE>
</BODY>
</HTML>

then the HTML behaves the same in both browsers.  

I would expect both of the samples to work identically.
(Reporter)

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 132915 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 2

16 years ago
Changing QA contact
QA Contact: petersen → amar
You need to log in before you can comment on or make changes to this bug.