Closed Bug 1329286 Opened 3 years ago Closed Last year

Remove |mach find-test-chunk| and related code from mochitest

Categories

(Testing :: General, defect)

defect
Not set

Tracking

(firefox63 fixed)

RESOLVED FIXED
mozilla63
Tracking Status
firefox63 --- fixed

People

(Reporter: ahal, Assigned: gbrown)

References

Details

Attachments

(1 file)

I think we should remove |mach find-test-chunk| because:

1) It's currently broken with a KeyError
2) It only ever worked with mochitest-plain to begin with
3) It's kind of inconvenient to use (need to type out a lot of command line args)
4) I'm not sure anyone ever verified how accurate it is

This bug will involve deleting the mach command itself, as well as removing related logic from the mochitest harness.
Duplicate of this bug: 1329285
Assignee: nobody → gbrown
Also, 'mach test-info' can be used to determine where (platform/suite/chunk) any test has recently run.
Depends on: 999450
:ahal - When you filed this bug, you said

> ... as well as removing related logic from the mochitest harness.

I don't see good candidates for removal from the mochitest harness. Were you thinking of removing support for 'dump_tests', or something like that? (It seems like a potentially useful argument.)
Attachment #9002086 - Flags: review?(ahal)
Comment on attachment 9002086 [details] [diff] [review]
remove 'mach find-test-chunk'

Review of attachment 9002086 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #9002086 - Flags: review?(ahal) → review+
Flags: needinfo?(gbrown)
https://hg.mozilla.org/mozilla-central/rev/eb4d9eac9c87
Status: NEW → RESOLVED
Closed: Last year
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
You need to log in before you can comment on or make changes to this bug.