Last Comment Bug 1329292 - Reason not able to get graphic in firefox 51 Beta 12
: Reason not able to get graphic in firefox 51 Beta 12
Status: RESOLVED INVALID
:
Product: Firefox
Classification: Client Software
Component: Untriaged (show other bugs)
: 51 Branch
: x86 Windows 8
-- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-01-06 11:40 PST by pushanshu
Modified: 2017-01-25 08:29 PST (History)
6 users (show)
bogdan.maris: needinfo? (subhrajyoti12)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: 1
Has Regression Range: ---
Has STR: ---


Attachments
10.png (38.44 KB, image/png)
2017-01-06 11:40 PST, pushanshu
no flags Details

Description User image pushanshu 2017-01-06 11:40:54 PST
Created attachment 8824517 [details]
10.png

User Agent: Mozilla/5.0 (Windows NT 6.2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36

Steps to reproduce:

1. Start Firefox.
2. Visit the following webpage (https://www.ibiblio.org/e-notes/Perc/contents.htm), select each demo and interract with them.
3.5. Visit the following demo (https://www.ibiblio.org/e-notes/webgl/gpu/bounce.htm) and interract with it.


Actual results:

Error message:-Experimental WebGL_2 based applications work only in Chrome 49 and Firefox 45 yet!


Expected results:

1. Firefox successfully starts.
2. Each demo is displayed as it should and the animations plays as expected with no visible lags or visual glitches.
3. The demo is displayed as it should and no visible lags or glitches are seen.
Comment 1 User image pushanshu 2017-01-06 11:45:00 PST
from testday6
Comment 2 User image Vlad Bacia-Mociran [:VladB] 2017-01-11 01:44:19 PST
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:53.0) Gecko/20100101 Firefox/53.0

Thanks for reporting this. Can you please load the same demo in Chrome Canary? Just to eliminate any Hardware limitations that you might have. 

I have tried to reproduce this issue on latest Nightly (Build ID: 20170110075905) and latest Beta v51.0b13 but couldn't. Can you provide more details regarding your graphic card ? 

Can you please retest this using latest Firefox Beta (https://goo.gl/XmzCrj) and latest Nightly build (https://nightly.mozilla.org/) and report back the results ? When doing this, please use a new clean Firefox profile, maybe even safe mode, to eliminate custom settings as a possible cause (https://goo.gl/PNe90E).
Comment 3 User image Vuyisile Ndlovu [:terrameijar] 2017-01-11 02:18:12 PST
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0

I was also unable to reproduce this bug.
Comment 4 User image Subhrajyoti Sen 2017-01-18 01:40:21 PST
[bugday-20170118] 
Was able to reproduce this on Nightly 52.0a2 (2017-01-17) (64-bit) on Linux Mint 64bit.
First demo showed " Experimental WebGL_2 based applications work only in Chrome 49 and Firefox 45 yet! "
Second demo showed a pop up saying "Can't get WebGL2"
Comment 5 User image Vlad Bacia-Mociran [:VladB] 2017-01-20 05:13:34 PST
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0

I have tried to reproduce this issue on Windows 8.1 and Ubuntu 14.04 with latest Dev build v52.0a2 and latest Nightly v53.0a1 (Build ID: 20170119222621) and couldn't. First demo showed "Experimental WebGL_2 based applications work only in Chrome 49 and Firefox 45 yet!" and the second demo was working without any issues.

Can you please retest this using latest Nightly build (https://nightly.mozilla.org/) and report back the results ?
Comment 6 User image Subhrajyoti Sen 2017-01-20 05:56:46 PST
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0

The issue with the second demo persists. I used the same nightly on another device too with the same result. Does this test need a dedicated graphics card as prerequisite?
Comment 7 User image Bogdan Maris, QA [:bogdan_maris] 2017-01-20 07:52:40 PST
(In reply to Subhrajyoti Sen from comment #6)
> User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:53.0) Gecko/20100101
> Firefox/53.0
> 
> The issue with the second demo persists. I used the same nightly on another
> device too with the same result. Does this test need a dedicated graphics
> card as prerequisite?

Hello. Yes you need a graphics card that supports webgl2. The easiest way to know this is by visiting this website http://webglreport.com/?v=2. It will tell if your PC can run WebGL 2.0. The browser supports webgl 2 (100%) but your hardware may not.
Please let me know what the website from above displays for you.
Comment 8 User image Subhrajyoti Sen 2017-01-20 07:57:26 PST
(In reply to Bogdan Maris, QA [:bogdan_maris] from comment #7)
> (In reply to Subhrajyoti Sen from comment #6)
> > User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:53.0) Gecko/20100101
> > Firefox/53.0
> > 
> > The issue with the second demo persists. I used the same nightly on another
> > device too with the same result. Does this test need a dedicated graphics
> > card as prerequisite?
> 
> Hello. Yes you need a graphics card that supports webgl2. The easiest way to
> know this is by visiting this website http://webglreport.com/?v=2. It will
> tell if your PC can run WebGL 2.0. The browser supports webgl 2 (100%) but
> your hardware may not.
> Please let me know what the website from above displays for you.

The website says "× This browser supports WebGL 2, but it is disabled or unavailable.

Sometimes this is the result of older video drivers being rejected by the browser. Try updating your video drivers if possible."
Looks like my graphics cared is outdated and does not support webgl 2. I am sorry for any confusion
Comment 9 User image Bogdan Maris, QA [:bogdan_maris] 2017-01-25 08:29:42 PST
Thanks for your reply. Since the reported did not answer, I will go ahead and mark this as invalid. Please reopen of log a new bug if this is reproducible on a PC that supports webgl2.

Note You need to log in before you can comment on or make changes to this bug.