Last Comment Bug 1329293 - Confusing error reported to console: "downloadable font: OS/2: adjusting Mac style (regular) ..."
: Confusing error reported to console: "downloadable font: OS/2: adjusting Mac ...
Status: RESOLVED FIXED
[
:
Product: Core
Classification: Components
Component: Graphics: Text (show other bugs)
: 51 Branch
: x86 Windows 8
-- normal (vote)
: mozilla53
Assigned To: Nobody; OK to take it and work on it
:
: Milan Sreckovic [:milan]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2017-01-06 11:49 PST by pushanshu
Modified: 2017-01-19 07:22 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: 2
Has Regression Range: ---
Has STR: ---
fixed


Attachments
9.png (141.89 KB, image/png)
2017-01-06 11:49 PST, pushanshu
no flags Details
Truncate overly long URIs in downloadable font error/warning messages (1.62 KB, patch)
2017-01-17 09:48 PST, Jonathan Kew (:jfkthame)
jmuizelaar: review+
Details | Diff | Splinter Review

Description User image pushanshu 2017-01-06 11:49:12 PST
Created attachment 8824518 [details]
9.png

User Agent: Mozilla/5.0 (Windows NT 6.2) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36

Steps to reproduce:

1. Launch Firefox and open the Browser Console from menu [≡] → select Developer → select Browser Console.
2. Visit about:plugins and check for the version of Shockwave flash
3. Browse through websites that use the Flash Player plug-in and look for rendering, functional and performance issues.


Actual results:

error in console


Expected results:

no error in console
Comment 1 User image Jerry Shih[:jerry] (UTC+8) 2017-01-15 21:48:45 PST
Is "plug-in" a better component to track this?
Comment 2 User image Benjamin Smedberg [:bsmedberg] 2017-01-17 06:39:31 PST
The errors in the console don't appear to have anything to do with Flash. They are font parsing notifications from web content. I can't tell whether those are errors or warnings or what, which appears to be because the URLS are very long data: and therefore cut off the end of the message. "downloadable font: OS/2: adjusting Mac style (regular) ..."

I don't know whether we can fix that by rearranging the message so that the complete message comes before the URL, or truncating the URL, or changing the display in the error console somewhat. But I'm going to move this to fonts first because I suspect that's the better option.

http://searchfox.org/mozilla-central/rev/790b2cb423ea1ecb5746722d51633caec9bab95a/layout/style/FontFaceSet.cpp#1221
Comment 3 User image Jonathan Kew (:jfkthame) 2017-01-17 08:59:32 PST
That's a warning (rather than an error) generated by OTS, here:

http://searchfox.org/mozilla-central/rev/790b2cb423ea1ecb5746722d51633caec9bab95a/gfx/ots/src/os2.cc#152

So the font data has internal inconsistencies that OTS is fixing up, but also reporting so that the author/font developer/whatever can be alerted to the fact that their font is not quite right.

Offhand, I'm not sure where the truncation of the message happens; AFAICS, we should be getting the full URI when we call GetFamilyNameAndURIForLogging at http://searchfox.org/mozilla-central/rev/790b2cb423ea1ecb5746722d51633caec9bab95a/layout/style/FontFaceSet.cpp#1206, but it's clearly truncated in the screenshot attached. Which is probably just as well, considering that a data: URI could be huge...

Perhaps we should truncate it within gfxUserFontEntry::GetFamilyNameAndURIForLogging itself. Probably center-truncation, so that we retain the beginning and end of a potentially over-long path, would be the most useful.
Comment 4 User image Jonathan Kew (:jfkthame) 2017-01-17 09:48:53 PST
Created attachment 8827542 [details] [diff] [review]
Truncate overly long URIs in downloadable font error/warning messages

I'd suggest we just do something simple-minded like this.
Comment 5 User image Jonathan Kew (:jfkthame) 2017-01-18 12:40:05 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/02fc9d9b46a58d20270c5dba699e3eef56370b80
Bug 1329293 - Truncate overly long URIs in downloadable font error/warning messages. r=jrmuizel
Comment 6 User image Carsten Book [:Tomcat] 2017-01-19 07:22:57 PST
https://hg.mozilla.org/mozilla-central/rev/02fc9d9b46a5

Note You need to log in before you can comment on or make changes to this bug.