firefox fails to build with system icu 58.2 at configure level.

RESOLVED DUPLICATE of bug 1329272

Status

()

Core
Build Config
RESOLVED DUPLICATE of bug 1329272
7 months ago
7 months ago

People

(Reporter: Hussam Al-Tayeb, Unassigned)

Tracking

53 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 months ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:53.0) Gecko/20100101 Firefox/53.0
Build ID: 20170105150411

Steps to reproduce:

 0:15.08 DEBUG: configure: error: cannot determine icu version number from uvernum.h header file

cat /usr/include/unicode/uvernum.h| grep 58
#define U_ICU_VERSION_MAJOR_NUM 58
#define U_ICU_VERSION_SUFFIX _58
#define U_ICU_VERSION "58.2"
#define U_ICU_VERSION_SHORT "58"
#define U_ICU_DATA_VERSION "58.2"
(Reporter)

Comment 1

7 months ago
I also saw sed: character class syntax is [[:space:]], not [:space:]

It looks like firefox build system doesn't like sed 4.3
downgrading to 4.2.2 gets rid of this issue.

Updated

7 months ago
Component: Untriaged → Build Config
Product: Firefox → Core

Comment 2

7 months ago
Looks like a dupe of bug 1329272.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1329272
You need to log in before you can comment on or make changes to this bug.