Please bring back "ask me every time" (cookies).

RESOLVED DUPLICATE of bug 1249151

Status

()

Firefox
Untriaged
RESOLVED DUPLICATE of bug 1249151
a year ago
a year ago

People

(Reporter: Thom Gardner, Unassigned)

Tracking

45 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20161215182741

Steps to reproduce:

Edit->Preferences->PrivacyTab  Check "Accept cookies" The "keep until" selection list used to have "ask me every time".


Actual results:

The afore mentioned selection list no longer contains "ask me every time".


Expected results:

I'd sure like to have "ask me every time" back again.  It gave me fine-grained control over what cookies I allowed, and from whom on my system in a convenient way.

Comment 1

a year ago
No, this option was a source of manys issues, even crashes.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1249151
(Reporter)

Comment 2

a year ago
Please consider bringing it back as a limited support, or even an unsupported feature.  Include "(unsupported)" in the selection title if you like.  Pop up a window when people select it saying "this thing can could some sites not to work, crashes, corruption of bodily fluids, loss of life and limb, and maybe even burn down your house with you and your dog still trapped inside..." if you like.  I've had a few issues with it from time to time myself, but I'm willing to put up with them.  I would usually deal with any problems caused by this by just refusing to visit those sites on which it has problems treating them as suspicious, or use my "dirty" account to fire up a second X session and visit them from there if I really needed to go there for some reason.

This feature, in addition to allowing me manage more easily who I might permit to use my own machine as a spy against me, also provided a valuable service as a canary in that dark and treacherous coal mine known as the Internet....

If not this, can you at least recommend (or perhaps author, if none such exists) a cookie manager plug-in which gives back some of this functionality, much like NoScript does for scripts and such....
You need to log in before you can comment on or make changes to this bug.