Closed Bug 1329533 Opened 3 years ago Closed 3 years ago

stylo: test_value_storage.html crashes with "called `Option::unwrap()` on a `None` value" on main thread without stack info

Categories

(Core :: CSS Parsing and Computation, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
firefox53 --- affected

People

(Reporter: xidorn, Assigned: xidorn)

References

Details

Attachments

(1 file)

It seems the crash happen on test_value_storage.html is a different one than bug bug 1323655.

To reproduce it, run ./mach mochitest --disable-e10s layout/style/test/test_value_storage.html and wait for a while.
Attached file testcase
This is a minimum testcase for this crash. It seems there is some issue getting background-position shorthand when background shorthand is set with a variable.
Assignee: nobody → xidorn+moz
Looks like this is the only crash blocking test_value_storage.html, and I have a fix for servo side now.
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Pushed by xquan@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/92b3a12591d1
Enable test_value_storage.html for stylo. DONTBUILD
You need to log in before you can comment on or make changes to this bug.