Moving a message to a folder via filter can cause the filter to trigger again (repeatedly, duplicate messages, replicate)

VERIFIED WORKSFORME

Status

MailNews Core
Filters
VERIFIED WORKSFORME
16 years ago
10 years ago

People

(Reporter: Vadim Berezniker, Assigned: Navin Gupta)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
While testing bug 104631, I noticed the following. It's possible to make mozilla
repeatedly duplicate a message. This was done on an IMAP account.
Create a filter -> "If subject contains testing1 move to INBOX"
Send a message to this account with subject "testing1" and watch the message
replicate.

(If you're wondering why you would want to move to INBOX, is because this can be
reproduced by moving from one IMAP account to another)
(Assignee)

Comment 1

16 years ago
I don't see any duplication or replication, the message is not replicated if
it is the same server and it is moved to Inbox on different server. 
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

16 years ago
yep. I don't see it anymore either.
(Assignee)

Comment 3

16 years ago
vrfy based on last comment
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.