Speaker icon in Youtube user channel video indicates mute state, but audio is playing.

RESOLVED WORKSFORME

Status

()

--
minor
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: alice0775, Assigned: chunmin)

Tracking

Trunk
x86
Windows 10
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [parity-chrome], URL)

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
This is not a recent regression.

Reproducible: always

Steps To Reproduce:
1. Open youtube user channel page ( ex. https://www.youtube.com/user/magaimonoshoji )
   --- observe speaker icon in video on top of the page

Actual Results:
Audio is playing as expected.
However, the status of speaker icon indicates MUTE(speaker icon with slash) 

Expected Results:
The status of speaker icon should indicate un-MUTE.
Chrome works as expected.
audio indicator?
Flags: needinfo?(alwu)
(Reporter)

Comment 2

2 years ago
Created attachment 8824938 [details]
screenshot

Comment 3

2 years ago
No, I guess it might caused by dispatching the error event from media element so that the website shows the wrong icon.
Flags: needinfo?(alwu)
Chunmin, 
Please have a look. 
JW and Alastor can help you if you need any help.
Assignee: nobody → cchang
(Assignee)

Comment 5

2 years ago
After brief discussion with Alastor, we found that it might be a svg issue(Thanks to Alastor!). 
The svg[0] of the shown "muted" icon, when it should to be "unmute", is actually correct. It[0] indeed is a unmuted icon. However, I have no idea why the screen shows a "muted" sign.
Fortunately, the "muted" icon[1] works fine.

CJ, I was wondering if you could give some opinions about this.

[0] https://jsfiddle.net/nwcyc7m9/ "unmute icon"
[1] https://jsfiddle.net/17abye4o/ "muted icon"
Flags: needinfo?(cku)
(Reporter)

Comment 6

2 years ago
No longer reproduce the problem.
It seems youtube have fixed their own code.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox53: affected → ---
Resolution: --- → WORKSFORME

Comment 7

2 years ago
   <path class="ytp-svg-fill" clip-path="url(#ytp-svg-volume-animation-slash-mask)" d="M 9.25,9 7.98,10.27 24.71,27 l 1.27,-1.27 Z" id="ytp-svg-38"></path>

This path is the slash to represent "mute". This path object has a clip-path attribute(ytp-svg-volume-animation-slash-mask) which clips out this slash. You can remove this attribute and see what happen.
Flags: needinfo?(cku)
You need to log in before you can comment on or make changes to this bug.