POST submission with only submit button fails

VERIFIED DUPLICATE of bug 129333

Status

()

Core
HTML: Form Submission
VERIFIED DUPLICATE of bug 129333
16 years ago
16 years ago

People

(Reporter: George Lund, Assigned: Alexandru Savulov)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
Submitting a form using the POST method, that only contains a submit button,
fails with the following error message:

request#no_content_length

As far as I know such a form is allowed; the form works fine in Internet Explorer.

Comment 1

16 years ago
reporter: wich build are you using?

wfm 2002020415 on linux

Comment 2

16 years ago
WFM on linux too, if this is indeed a bug, it seems to be a windows-specific one.
I do suspect that this might be an issue with the server side of things.

Reporter: can you supply a testcase?

I created a php script which submitted to itself, and that worked regardless
of name/value on the submit or lack thereof.

Comment 3

16 years ago
WFM
build id: 2002032203
OS: Windows 2000
George, which build are you using?
(Reporter)

Comment 5

16 years ago
Sorry to have been so long in repsonding; my Hotmail account was having problems.

To respond to the questions: I thought Bugzilla included details of the build I
was using automatically, sorry: 0.9.9 anyway.

The URL given above is the test case, and the response that is received upon
pressing the submit button is "Invalid Request". Here it is again:
<http://lundbooks.co.uk/test.php>

However I am beginning to think this may be a problem with our web server rather
than Mozilla. Of course I would be grateful if anyone could let me know if that
is the case - and what to do about it! Thing is - it does work fine in IE.

Thanks
George, you're going to have to provide more information on steps to reproduce 
and especially on how to tell a successful submission from a failed one.  When 
I submit with a current Linux trunk build I get no error message but just the 
test.php page again.
(Reporter)

Comment 7

16 years ago
Well if this can't be pinned down then so be it. It could be something peculiar
to our connection (tho' I did try with two different ISPs and via a proxy
server). The full message I get is:

request#no_content_length
-------
Description: Unable to process request for URL"http://lundbooks.co.uk/test.php".
-------

If I use a proxy server I get that proxy server's custom error response,
indicating that Mozilla sent an "invalid request". As I say, in IE there's no
error message, the page is just reloaded as you would expect (and as you seem to
get in Mozilla). We run Windows 2000. Sorry I can't think of anything else that
might explain it!

Comment 8

16 years ago
the form wfm with a cvs build from today on win2k. I get the same results in 
mozilla as I do in IE6.
Ah.  Of course.  "request#no_content_length" means the request has no
content-length header....

Duplicate of "Submitting form creates bad request according to squid" (we were
not putting content-length on some requests, fixed March 12).

*** This bug has been marked as a duplicate of 129333 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 10

16 years ago
verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.