Status

defect
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: njn, Assigned: njn)

Tracking

unspecified
Thunderbird 53.0
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Assignee

Description

3 years ago
Bug 1329857 is going to remove NS_METHOD. The handful of uses in mailnews/ can
be replaced easily.
Assignee

Comment 1

3 years ago
Attachment #8825270 - Flags: review?(rkent)

Comment 2

3 years ago
Comment on attachment 8825270 [details] [diff] [review]
Remove NS_METHOD uses

Thanks. Looks like we should land this now since bug 1329857 has already landed and were practically busted.

Just for my education: What's NS_IMETHODIMP?
Attachment #8825270 - Flags: review?(rkent) → review+

Comment 3

3 years ago
https://hg.mozilla.org/comm-central/rev/29fb1e7ca57265c7a8fcdedaac46811adcc28056
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 53.0
Assignee

Comment 4

3 years ago
> Just for my education: What's NS_IMETHODIMP?

IDL-style methods use NS_IMETHOD for their declaration, and NS_IMETHODIMP for their definition (if they have an out-of-class definition).

NS_IMETHOD expands to |virtual nsresult|, and NS_IMETHODIMP expands to |nsresult|. And on Windows, they both also include something extra to use a different calling convention (i.e. the one used by xptcall).

Comment 5

3 years ago
Thanks.

Could you kindly CC or r? me in the future since I'm usually faster than Kent. I'm also the dedicated TB maintainer and looking after trunk, Aurora, Beta and ESR. I only found this bug by accident (scanning new bugs for regressions) and had I not seen it, we would have run into (yet another) bustage. Of course I know that you usually give us heads-up and patches, which is much appreciated. So thanks again.
Assignee

Comment 6

3 years ago
I'll try to remember to CC Jorg next time!
You need to log in before you can comment on or make changes to this bug.