Profiling bug 1269695 with the Gecko Profiler makes us spend ~500ms in ObjectGroup::findAllocationSite

RESOLVED DUPLICATE of bug 1329873

Status

()

Core
JavaScript Engine: JIT
RESOLVED DUPLICATE of bug 1329873
a year ago
a year ago

People

(Reporter: Ehsan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
STR:

1. Use a clean profile on Nightly and install the Gecko Profiler add-on from https://new.cleopatra.io/
2. Make sure the profiler is running, and the "Show JIT Optimizations" checkbox under the Performance tab of devtools is off.
3. Profile bug 1269695 using Instruments, with Gecko Profiler also running.
4. See the screenshot which is the call to ObjectGroup::findAllocationSite().
(Reporter)

Comment 1

a year ago
Looks like I filed this twice!  One bug is probably enough.  :-)
No longer blocks: 1269695
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1329873
You need to log in before you can comment on or make changes to this bug.