Closed Bug 1329911 Opened 3 years ago Closed 3 years ago

Firefox v50 ignore form post data when connection failed But v49 or older work

Categories

(Core :: Networking, defect)

50 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla53
Tracking Status
firefox50 --- wontfix
firefox51 --- wontfix
firefox52 --- fixed
firefox53 --- fixed

People

(Reporter: abhijitk260, Unassigned)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached image Untitled-2.jpg
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36

Steps to reproduce:

Extra details on this link:
https://support.mozilla.org/en-US/questions/1153222

I want to resend popup dialog box its not come when my connection failed for other reason of page load failed("Problem loading page"). The latest version of firefox not show on failed page "Try Again" to load that page.

I just click on "Try Again"
Firefox v49 or older give me popup dialog box for "Resend" data.
but latest not giving me that ("Problem loading page" times).
I tried 4 - 5 pcs.
I entry some dada on website and i really need this "resend" popup, otherwise my form fillup work going waste of time, there are a lot of fields to fillup. I uninstall latest version of firefox and use firefox V49. So please HELP me I really want to use latest version of firefox.


Actual results:

Firefox v50(latest) remove POST method and turn it into GET method request.
But firefox v49 give me "Resend" popup on "Problem loading page" time.
I want this dialog box on latest version of firefox.


Expected results:

"Resend" popup dialog box on "Problem loading page"
STR:
1) Open https://www.jeffersonscher.com/res/posttest.html
2) Disable Internet
3) Submit the form until the page "Unable to connect" appears
4) Enable Internet
5) Press "Try again"

Result: you don't have the dialog box about resend data.

Reg range:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=820961ff0369ddab74419085c64fac957d1be0b3&tochange=86816e25dea7cfcc8adbb70c575a04c8fa7be278

Wei-Cheng Pan — Bug 1264566 - Part 3: Release upload stream after request complete. r=valentin
Blocks: 1264566
Status: UNCONFIRMED → NEW
Has Regression Range: --- → yes
Has STR: --- → yes
Component: Untriaged → Networking
Ever confirmed: true
Flags: needinfo?(wpan)
OS: Unspecified → All
Product: Firefox → Core
Hardware: Unspecified → All
I think this is related/duplicate to bug 1304056.

For now I think we can back out that patch to fix the behavior.
Flags: needinfo?(wpan)
This issue is not only isolated to e10s. Normal mode is affected too.
From what I understand, the patch is trying to release the upload stream for content process, but to do this, it also closed the one in parent process, which may be used later for re-send. This affects both e10s and non-e10s.

Back out the patch should make the re-send works properly, but the mUploadStream will not be released in content process (in e10s mode). That's what bug 1304056 wants to solve.
(Correct me if I'm wrong)
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1304056
I will test the POST behavior without rev 0476118cfea7aef2cb676cc9a78b6ce109cab270.
Then I'll request a backout if that solves the problem.
After the test, I have to backout rev 0476118cfea7aef2cb676cc9a78b6ce109cab270 (in bug 1264566 part 3) and rev 8cc4907776c85b5f57c1778bdd5b2a4ad8eb8055 (in bug 1293765) to get it work again.

:mayhemer, how would you feel if I request to backout bug 1293765 with bug 1264566 part 3?
Flags: needinfo?(honzab.moz)
Moving status flags to fix optional to get this off the release health dashboard. Will move the flags to the dupe noted in Comment 5.
(In reply to Wei-Cheng Pan [:wcpan] [:wcp] [:legnaleurc] from comment #7)
> After the test, I have to backout rev
> 0476118cfea7aef2cb676cc9a78b6ce109cab270 (in bug 1264566 part 3) and rev
> 8cc4907776c85b5f57c1778bdd5b2a4ad8eb8055 (in bug 1293765) to get it work
> again.
> 
> :mayhemer, how would you feel if I request to backout bug 1293765 with bug
> 1264566 part 3?

Yeah, bug 1293765 was not enough to fix the mess caused by bug 1264566.  I'm all for backing them out (thought we already did that...), we need to find a better solution.
Flags: needinfo?(honzab.moz)
Reopen this bug because this is related to bug 1304056, not duplicated.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Since it is somewhat complicated to describe bugs to back out, I just made a patch which reverts bug 1264566 part 3 and bug 1293765.
I don't understand what going on here. I need the ans, How? how i fix this problem with options?
Comment on attachment 8826524 [details]
Bug 1329911 - Fix incorrect releasing of POST data.

https://reviewboard.mozilla.org/r/104478/#review105748

Thanks!
Attachment #8826524 - Flags: review?(honzab.moz) → review+
Pushed by wpan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/792c6f70dde5
Fix incorrect releasing of POST data. r=mayhemer
https://hg.mozilla.org/mozilla-central/rev/792c6f70dde5
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Comment on attachment 8826524 [details]
Bug 1329911 - Fix incorrect releasing of POST data.

Approval Request Comment
[Feature/Bug causing the regression]: bug 1264566, bug 1293765
[User impact if declined]: They won't be able to re-send POST data in certain situation.
[Is this code covered by automated tests?]: No.
[Has the fix been verified in Nightly?]: Yes.
[Needs manual test from QE? If yes, steps to reproduce]: See comment 1.
[List of other uplifts needed for the feature/fix]: None.
[Is the change risky?]: No.
[Why is the change risky/not risky?]: This patch just restores the behavior of POST-ing prior to 50.
[String changes made/needed]: None.
Attachment #8826524 - Flags: approval-mozilla-release?
Attachment #8826524 - Flags: approval-mozilla-beta?
Attachment #8826524 - Flags: approval-mozilla-aurora?
(In reply to Abhijit Kumar from comment #13)
> I don't understand what going on here. I need the ans, How? how i fix this
> problem with options?

I think we need to wait for a point release to get this fix.
Comment on attachment 8826524 [details]
Bug 1329911 - Fix incorrect releasing of POST data.

Revert to pre-Firefox 50 behavior to retry posting data. 
Let's uplift this to aurora, for Firefox 52. It is very late in the beta cycle to take this for 51.
Attachment #8826524 - Flags: approval-mozilla-release?
Attachment #8826524 - Flags: approval-mozilla-release-
Attachment #8826524 - Flags: approval-mozilla-beta?
Attachment #8826524 - Flags: approval-mozilla-beta-
Attachment #8826524 - Flags: approval-mozilla-aurora?
Attachment #8826524 - Flags: approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.