Rendering completely broken on nightly 53.0a1 (2017-01-09) (64-bit)

RESOLVED WORKSFORME

Status

()

P3
normal
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: saurabh8c, Unassigned)

Tracking

({regressionwindow-wanted})

53 Branch
x86_64
Windows 10
regressionwindow-wanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8825313 [details]
screenshot of firefox report issue page as rendered at 90% zoom

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.79 Safari/537.36 Edge/14.14393

Steps to reproduce:

Open any website/local page in build 53.01a(2017-01-09). 


Actual results:

Most part of screen doesn't renders at all. This is happening with any content (text, input, images). Renders correctly after size change/zoom.


Expected results:

Pages should have rendered correctly.
Attaching screenshot of firefox report issue page as rendered at 90% zoom. The page renders correctly at 140%
(Reporter)

Updated

2 years ago
Severity: normal → blocker
OS: Unspecified → Windows 10
Priority: -- → P1
Hardware: Unspecified → x86_64

Updated

2 years ago
Severity: blocker → normal
Component: Untriaged → Graphics
Priority: P1 → --
Product: Firefox → Core

Comment 1

2 years ago
Could you test with HWA disabled, please (restart FF to apply).
https://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration


In addition, type about:support and copy here the section "graphics".
Flags: needinfo?(saurabh8c)
(Reporter)

Comment 2

2 years ago
Rendering works correctly with HWA disabled.

Graphics
Features
Compositing	Basic
Asynchronous Pan/Zoom	wheel input enabled; touch input enabled; scrollbar drag enabled
WebGL Renderer	Google Inc. -- ANGLE (NVIDIA Quadro K420 Direct3D9Ex vs_3_0 ps_3_0)
WebGL2 Renderer	WebGL creation failed: * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Error during ANGLE OpenGL init. * Exhausted GL driver caps.
Hardware H264 Decoding	No; Hardware video decoding disabled or blacklisted
Audio Backend	wasapi
DirectWrite	true (10.0.14393.351)
GPU #1
Active	Yes
Description	NVIDIA Quadro K420
Vendor ID	0x10de
Device ID	0x0ff3
Driver Version	21.21.13.7295
Driver Date	9-22-2016
Drivers	C:\WINDOWS\System32\DriverStore\FileRepository\nvwu.inf_amd64_e8832672c6cd8351\nvd3dumx,C:\WINDOWS\System32\DriverStore\FileRepository\nvwu.inf_amd64_e8832672c6cd8351\nvwgf2umx,C:\WINDOWS\System32\DriverStore\FileRepository\nvwu.inf_amd64_e8832672c6cd8351\nvwgf2umx,C:\WINDOWS\System32\DriverStore\FileRepository\nvwu.inf_amd64_e8832672c6cd8351\nvwgf2umx C:\WINDOWS\System32\DriverStore\FileRepository\nvwu.inf_amd64_e8832672c6cd8351\nvd3dum,C:\WINDOWS\System32\DriverStore\FileRepository\nvwu.inf_amd64_e8832672c6cd8351\nvwgf2um,C:\WINDOWS\System32\DriverStore\FileRepository\nvwu.inf_amd64_e8832672c6cd8351\nvwgf2um,C:\WINDOWS\System32\DriverStore\FileRepository\nvwu.inf_amd64_e8832672c6cd8351\nvwgf2um
Subsys ID	1106103c
RAM	1024
Diagnostics
ClearType Parameters	DISPLAY1 [ Gamma: 2.2 Pixel Structure: RGB ClearType Level: 0 Enhanced Contrast: 400 ] DISPLAY2 [ Gamma: 2.2 Pixel Structure: RGB ClearType Level: 50 Enhanced Contrast: 200 ]
AzureCanvasAccelerated	0
AzureCanvasBackend	skia
AzureContentBackend	skia
AzureFallbackCanvasBackend	cairo
ClearType Parameters	DISPLAY1 [ Gamma: 2.2 Pixel Structure: RGB ClearType Level: 0 Enhanced Contrast: 400 ] DISPLAY2 [ Gamma: 2.2 Pixel Structure: RGB ClearType Level: 50 Enhanced Contrast: 200 ]
Decision Log
HW_COMPOSITING	
disabled by user: Disabled by pref
D3D11_COMPOSITING	
unavailable by default: Hardware compositing is disabled
D3D9_COMPOSITING	
unavailable by default: Hardware compositing is disabled
DIRECT2D	
unavailable by default: Direct2D requires Direct3D 11 compositing
D3D11_HW_ANGLE	
unavailable by default: D3D11 compositing is disabled
disabled by env: D3D11 compositing is disabled
GPU_PROCESS	
unavailable by env: Not using GPU Process since D3D11 is unavailable
Flags: needinfo?(saurabh8c)

Comment 3

2 years ago
Probably a dupe of bug 1325944.
Depends on: 1325944

Updated

2 years ago
Keywords: regression
Is it possible to run mozregression and see when this problem started?
Flags: needinfo?(saurabh8c)
Priority: -- → P3
Whiteboard: [gfx-noted]
regression window wanted per comment 4
Keywords: regression → regressionwindow-wanted
(Reporter)

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(saurabh8c)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.