firefox will not play facebook videos, and there is no add on that will play them. None, I tried and looked.

RESOLVED INVALID

Status

()

Core
Audio/Video: Playback
RESOLVED INVALID
9 months ago
8 months ago

People

(Reporter: eric, Unassigned)

Tracking

50 Branch
Unspecified
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 months ago
User Agent: Mozilla/5.0 (Windows NT 6.0; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161208153507

Steps to reproduce:

tried an add on; it failed. opened and closed pages, did not change anything



Expected results:

Just play the videos! what's with all the bureaucracy with this browser?
(Reporter)

Updated

9 months ago
OS: Unspecified → Windows Vista

Comment 1

9 months ago
Probably because your Vista machine doesn't have the media Microsoft API used by Firefox to play MP4.
Vista is outdated.

Updated

9 months ago
Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core
(Reporter)

Comment 2

9 months ago
Or Firefox doesn't supply adequate means to play videos. Why do computer folks think we should go out and buy new systems all the time? (whatever "API" means; I looked it up, by why speak in geekese?)
Please check that you have installed the Windows Media Pack from Microsoft. 

You can find instructions on what to do there:
https://support.mozilla.org/en-US/kb/fix-video-audio-problems-firefox-windows

Download the vista one; restart Firefox and you should be good to go
(Reporter)

Comment 4

9 months ago
I have windows media pack 1, according to the label on my computer. The update available at that link would not work; apparently I need windows media pack 2. It odes not seem to be available; where is it?
Thanks.

Updated

9 months ago
Duplicate of this bug: 1330081
You need to follow the instructions here https://support.microsoft.com/en-nz/help/13858/windows-vista-service-pack-2-install to install SP2 first.
Chris - I can't seem to edit Sumo for some reason. Can you add that link into the article for Vista as a note for people with out SP2?
Flags: needinfo?(cpeterson)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → INVALID
(In reply to Anthony Jones (:kentuckyfriedtakahe, :k17e) from comment #7)
> Chris - I can't seem to edit Sumo for some reason. Can you add that link
> into the article for Vista as a note for people with out SP2?

I submitted a change to the SUMO article, though the change won't be live until a SUMO person reviews.
Flags: needinfo?(cpeterson)
You need to log in before you can comment on or make changes to this bug.