[compact layout] Increase tile title background opacity to improve legibility

RESOLVED FIXED in Firefox 51

Status

()

defect
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: dao, Assigned: dao)

Tracking

(Blocks 1 bug, {access})

Trunk
Firefox 53
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox51 verified, firefox52 fixed, firefox53 fixed)

Details

Attachments

(1 attachment)

Posted patch patchSplinter Review
Since we render the title above the thumbnail, we need to make sure this provides enough contrast including for pathological cases with noisy thumbnails.
Attachment #8825340 - Flags: review?(gijskruitbosch+bugs)
Comment on attachment 8825340 [details] [diff] [review]
patch

Review of attachment 8825340 [details] [diff] [review]:
-----------------------------------------------------------------

rs=me on the assumption we 'need' to update the bg opacity to .85, though I'm curious on what kind of thumbnails this makes a difference.
Attachment #8825340 - Flags: review?(gijskruitbosch+bugs) → review+
(In reply to :Gijs from comment #1)
> Comment on attachment 8825340 [details] [diff] [review]
> patch
> 
> Review of attachment 8825340 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> rs=me on the assumption we 'need' to update the bg opacity to .85, though
> I'm curious on what kind of thumbnails this makes a difference.

from IRC:

<dao> Gijs: the STR is really just "have a tile with a noisy thumbnail, and have not so great eyesight." amazon.com works well as a testcase over here since it has black and white parts at the bottom
<dao> though this could depend on your window size, whether you're logged in on amazon, etc.
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/b1bed58dbb66
[compact layout] Increase tile title background opacity to improve legibility. r=gijs
Comment on attachment 8825340 [details] [diff] [review]
patch

Approval Request Comment
[Feature/Bug causing the regression]: bug 1322718 / bug 1322738

[User impact if declined]: possible subpar legibility of about:newtab tile titles in the funnelcake build

[Is this code covered by automated tests?]: /

[Has the fix been verified in Nightly?]: not yet

[Needs manual test from QE? If yes, steps to reproduce]: probably just as part of bug 1322738

[List of other uplifts needed for the feature/fix]: /

[Is the change risky?]: no

[Why is the change risky/not risky?]: trivial adjustment of background color alpha value. The patch looks a bit larger than strictly necessary because I'm merging two CSS rules.

[String changes made/needed]: /
Attachment #8825340 - Flags: approval-mozilla-beta?
Attachment #8825340 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/b1bed58dbb66
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 53
Comment on attachment 8825340 [details] [diff] [review]
patch

styling update for about:newtab, aurora52+/beta51+, should be in 51.0b14
Attachment #8825340 - Flags: approval-mozilla-beta?
Attachment #8825340 - Flags: approval-mozilla-beta+
Attachment #8825340 - Flags: approval-mozilla-aurora?
Attachment #8825340 - Flags: approval-mozilla-aurora+
[bugday-20170125]
You need to log in before you can comment on or make changes to this bug.