Closed Bug 1330124 Opened 5 years ago Closed 5 years ago

WE completely unsuitable for replacement the addon-SDK

Categories

(WebExtensions :: Experiments, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1215059

People

(Reporter: fdsc, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161208153507

Steps to reproduce:

Attempt to use WebExtensions for replacement addons SDK in extensions is impossible.
Mozilla policy is that Mozilla is trying on the one hand  the Mozilla can copy WE from other browsers. On the other hand Mozilla tries to replace the addons SDK by WE.


Actual results:

Mozilla refuses the changes WE due to the fact that this is not the same as the behavior WE have been in other browsers. While the addons SDK can't be replaced by WE, if WE will be like in other browsers.


Expected results:

If Mozilla wants to go on WE, Mozilla need to work out a policy on the WE so that it would be possible to write an add-on has already been written with the addons SDK.
At this point in time is fundamentally impossible with given the Mozilla policy.
Severity: normal → major
Severity: major → normal
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
See Also: → 1279371, 1330590
Decisions about which APIs to support happen in public triage meetings, which you're welcome to attend:

https://wiki.mozilla.org/Add-ons/Contribute/Triage
Flags: needinfo?(kmaglione+bmo)
Thank you. However, I do not understand, how access for "public triage meetings". And I'm afraid it is very inconvenient. When you have day we have night. And I don't know English enough to chat in real-time.

Is there any other way?
Flags: needinfo?(kmaglione+bmo)
(In reply to fdsc from comment #4)
> Thank you. However, I do not understand, how access for "public triage
> meetings". And I'm afraid it is very inconvenient. When you have day we have
> night. And I don't know English enough to chat in real-time.
> 
> Is there any other way?

Commenting on individual bugs, giving specific examples about how you would use a proposed new API is probably the most helpful.
I recognize that is more work for you, but its much more helpful for us and much more likely to lead to concrete results than overly general bugs such as this one.
(In reply to fdsc from comment #4)
> Thank you. However, I do not understand, how access for "public triage
> meetings". And I'm afraid it is very inconvenient. When you have day we have
> night. And I don't know English enough to chat in real-time.

We currently schedule the meetings so they're reasonably convenient for most of the Americas and Europe, since that's where most of our current attendees are located. If you're interested in attending and the time doesn't work for you, please send an email to the dev-addons mailing list, and we'll try to work something out.

Otherwise, as Andrew says, commenting on bugs, or bringing the discussion to the mailing list, is your best bet.
Flags: needinfo?(kmaglione+bmo)
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.