embed tag with hidden attribute does not hide properly

RESOLVED DUPLICATE of bug 136456

Status

()

P4
normal
RESOLVED DUPLICATE of bug 136456
17 years ago
16 years ago

People

(Reporter: jthg, Assigned: peterl-bugs)

Tracking

({compat, testcase})

Trunk
compat, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.9+)
Gecko/20020318
BuildID:    2002031803

An embed tag with a hidden attribute displays a transparent box moving all
content below it.  An example of the tag is:
<embed src="file.midi" hidden="true">

Reproducible: Always
Steps to Reproduce:
1. View a page with a embed tag with the hidden atribute


Actual Results:  All the content is moved down below an invisible box that the
embed tag created.

Expected Results:  The embed tag should not have rendered anything on the
screen.  The content should have been been moved up.

See attachment of the test case.
(Reporter)

Comment 1

17 years ago
Created attachment 75773 [details]
embed tag with  hidden atrribute
The <embed> tag is not standard HTML, nor is the "hidden" attribute.  Hiding it with CSS should be effective.  Should probably be WONTFIX or INVALID.
Keywords: compat, testcase
Whiteboard: WONTFIX
(Reporter)

Comment 3

17 years ago
Maybe this topic should be another bug, but on my computer the sound is not
played.  I always assumed that it was because a helper application on my
computer was not set up correctly; but, if mozilla does not support the embed
tag (and that is the reason why their is not music on the web page), then
mozilla should ignore it and not display anything regardless of the fact that
their is a hidden attribute or not.

Am I understanding everything correctly?
I think <embed> may be necessary for IE; we may support it too, for
compatibility.  Try wrapping the <embed> tag in an <object> tag with the
appropriate attributes: data="location of file" and type="MIME-type of file",
and I think it should work.  

You are correct that the "hidden" attribute should not affect Mozilla's handling.

I'm going to resolve this bug; the above solution should make the object
invisible, anyway.  Good luck!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX
Um...  I'm sorry, but I disagree.  Reopening.

We _do_ handle the "hidden" attribute.  We map it to "visibility:hidden" in CSS.
 Unfortunately, both IE and NS4 act more like "height:0; width:0" (or maybe even
"display:none") in response to that attribute.

This should be fixed, imo.
Status: RESOLVED → UNCONFIRMED
OS: Windows NT → All
Hardware: PC → All
Resolution: WONTFIX → ---
Whiteboard: WONTFIX

Comment 6

17 years ago
Changing QA contact
QA Contact: petersen → moied

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P4
Looks like a ObjectFrame - plugin issue. Reassigning to peterl.
Assignee: attinasi → peterl

Comment 8

17 years ago
Nope, this is broken :( Patch in bug 136456 will fix this.

Note: We don't map it to visibility as according to CSS spec this leaves space
in layout while the hidden attribute acts more like display:none in 4.x. We
can't use display:none at this time because plugins are tied to frames.

Does anyone know if I.E. or 4.x support the hidden attribute on applet tags?

*** This bug has been marked as a duplicate of 136456 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.