Status

()

Firefox
Screen Sharing Whitelist
RESOLVED WONTFIX
a year ago
a year ago

People

(Reporter: admin, Unassigned)

Tracking

Trunk
All
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
>> Vendor name
Fakturabank.no

>> Point of contact
admin@fakturabank.no

>> Site URLs
fakturabank.no
*.fakturabank.no

>> Does the application provide users with notice and control?
The Service is used to provide support for using fakturabank.no application.
Screen sharing is transmitting only the specific content that the user directs to be transmitted (“User Directed Content”)
Voice and video communicated is not stored anywhere in our system.
Chat messages might be stored in our system to be able to provide a chat message history for a user and supporter.

>> Have you seen and agree with the Developer Screen Sharing Submission policy?
Yes

>> Does the usage comply with the Developer Screen Sharing Submission Policy guidelines?
Yes

Comment 1

a year ago
Hi, I am resolving this bug as "won't fix", since starting Firefox 52 on April 18th the Screensharing whitelist is no longer needed to share your screen or windows. Please let us know if you find any problems!

        Much of this work was front-end, UX/UI changes, including support to let the UI know what streams are "scary" to share (see bug 1284910). See the meta bug 1127522 for all the work that went into this.

        Please read Jan-Ivar's blog post explaining the risks that users need to know about when sharing their screen or windows: https://blog.mozilla.org/webrtc/share-browser-windows-entire-screen-sites-trust/.

        The new UI permission dialog for screensharing links to a SUMO article with similar content to Jan-Ivar's post, but our SUMO team tailored it to a less technical user.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.