Videos on YouTube render only green, gray, and purple in both the latest beta and stable

RESOLVED WORKSFORME

Status

()

Firefox for Android
Toolbar
RESOLVED WORKSFORME
a year ago
a year ago

People

(Reporter: Jonwsb, Unassigned, NeedInfo)

Tracking

51 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8826094 [details]
tmp_26928-Screenshot_20170112-0258351647298763.png

User Agent: Mozilla/5.0 (Android 6.0.1; Mobile; rv:51.0) Gecko/51.0 Firefox/51.0
Build ID: 20170110094327

Steps to reproduce:

Opened any video on YouTube using either mobile or desktop mode.


Actual results:

Video rendered everything tinted green and purple and misaligned.


Expected results:

Normal video playback.
Hello and thank you for the report.

Tested on latest Beta 51.0b13 and release versions using:
- Nexus 5 (Android 6.0.1);
- Huawei Honor 5x (Android 5.1.1).

The videos were displayed correctly and there were no issues related to the colors of the videos with both mobile and Desktop mode.

Can you please provide more information about the device and the OS you are using to reproduce this issue?
Also, can you try with a clean profile and see if the issue is still reproducing? Go to your device settings -> Applications -> Application manager -> choose Firefox Beta -> Storage -> Clear Data.
Flags: needinfo?(Jonwsb)
Since this report is related to a displaying issue of the video, I'm moving this to Audio/Video component.
Component: General → Audio/Video
(Reporter)

Comment 3

a year ago
The model phone I'm having issues with is the OnePlus X running CyanogenMod 13.0-20161404-NIGHTLY-onyx though the issue happened with older Cyanogen versions as well. I cleared Firefox's data but it did not fix the rendering issue. Other video websites work properly as well as the YouTube app.
This seems more related to graphics. Change the component to get more ideas from gfx guys.
Component: Audio/Video → Graphics, Panning and Zooming
snorp, did you have a OnePlus X lying around?
Flags: needinfo?(Jonwsb) → needinfo?(snorp)
I don't have one. John, do you want to take a look at this?
Flags: needinfo?(snorp)
Flags: needinfo?(jolin)
Flags: needinfo?(bwu)
From the screenshot, it looks like something's wrong with the chroma plane. Will try reproducing by installing Cyanogen on my Nexus 5.

Jonwsb, could you please also help run 'adb shell bugreport' when playing the video and upload the output? Thanks a lot.
Flags: needinfo?(jolin)
Flags: needinfo?(bwu)
Flags: needinfo?(Jonwsb)
CyanogenMod on Nexus 5 looks fine. I guess OnePlus X is needed for reproducing after all.
No response from reporter, and we can't reproduce this on devices we have. Closing as WFM for now - Jonwsb, please feel free to reopen if you can provide the requested data. Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.