[Ubuntu] Add-on notification pop-ups are not simultaneously displayed

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: vasilica.mihasca, Unassigned)

Tracking

Trunk
All
Linux
Points:
---

Firefox Tracking Flags

(firefox50 affected, firefox51 affected, firefox52 affected, firefox53 affected)

Details

(Whiteboard: [fxprivacy])

[Affected versions]:
Firefox 53.0a1 (2017-01-11)
Firefox 52.0a2 (2017-01-11)
Firefox 51.0b13 (20170109165508)
Firefox 50.1.0 (20161208153507) 

[Affected platforms]:
Ubuntu 16.04 32-bit
Ubuntu 12.04 64-bit

[Steps to reproduce]:
1.Launch Firefox with clean profile.
2.Navigate to https://addons.mozilla.org
3.Choose an add-on and click on “+ Add to Firefox” green button. 
4.Continue the installation process by clicking on “Install” button from doorhanger.
5.While the confirmation pop-up is still displayed, choose another add-on and click on “+ Add to Firefox” green button.

[Expected Results]:
The second add-on doorhanger appears under the first one. 

[Actual Results]:
- The first pop-up is replaced by the second one.
- See screencast: https://www.dropbox.com/s/6uhag5389s3czjh/out-6.ogv?dl=0 

[Additional Notes]:
- This issue is not reproducible on Windows or Mac platforms.
I'd call this a feature :P

Since this is not a regression (and it actually looks better than the other platforms), I'm not sure if we ever want to fix it. According to Markus, the new addon install flow will do away with the stacked doorhangers anyway.
Whiteboard: [fxprivacy] [triage]
Philipp/Markus: We're thinking that this still has a workaround (dismissing the one prompt before the other) and should therefore be lower priority or wontfix, but what is the expected behavior?
Flags: needinfo?(psackl)
Flags: needinfo?(mjaritz)
(In reply to Johann Hofmann [:johannh] from comment #1)
> I'd call this a feature :P
I agree.

(In reply to Peter Dolanjski [:pdol] from comment #2)
> Philipp/Markus: We're thinking that this still has a workaround (dismissing
> the one prompt before the other) and should therefore be lower priority or
> wontfix, but what is the expected behavior?

The behaviour looks good to me. It displays the most recent doorhanger. I expect the re-install will re-appear once the other one is dismissed.

Overall we would like to get away from stacking doorhangers and instead always display the most recent.
A next version will make the install prompt modal, and add-ons that require a restart will become less. Therefor there should be less and less ways to make doorhangers stack or overlay each other. Which is where we would like to be.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(psackl)
Flags: needinfo?(mjaritz)
Resolution: --- → WONTFIX
Whiteboard: [fxprivacy] [triage] → [fxprivacy]
You need to log in before you can comment on or make changes to this bug.