Tooltip obscures bookmark folders in toolbar blocking drag-and-drop




16 years ago
9 years ago


(Reporter: Derwood, Unassigned)



Firefox Tracking Flags

(Not tracked)



(1 attachment)



16 years ago
2002032203 on win2Kpro-sp2

When the bookmark icon is clicked on next to the location bar, the tooltip pops
up just underneith obscruting existing bookmark folders and preventing the
drag-and-drop of the new bookmark.
I'm having the same problem. If I drag an url icon to a folder in my personal
bar, a "Drag and drop this icon to create a link to this page." tooltip appears
over my folder and I am unable to release the url.

Steps to reproduce:

1- Open Bookmarks>Manage Bookmarks...
2- Under your personal bar, create a folder.
3- Open a website.
4- Drag the url in the location bar to the folder.

Expected results
You add the url to your folder

Actual results
A tooltip appears and you are unable to add the link until the tooltip disapears.

My configuration: Win2k, build(2002032003)
Created attachment 75861 [details]
Screenshot of the problem
Seems like the position of this tootip is fixed, so this problem only occurs
when you drag the link to a folder that's in the area where the tooltip will appear.

Comment 4

16 years ago
I have the same problem.  Easily reproducable, and annoying as sin ;)
It'd be nice if the tooltip would either disappear, or be 'transparent' - you
can drag and drop the link through the tooltip.
This is using Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020313.

Comment 5

16 years ago
Sorry, I should have added to my comment that in order to get around this, I
hold my mouse button down until the tooltip disappears, I can then drop the link
onto any of the folders that were blocked by the tooltip.
Again, this is using Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9)

Comment 6

16 years ago
Confirming on Windows XP Pro with 2002040503

Quick fix could be to kill the tooltip on mouse move...

Comment 7

16 years ago
Marking Confirmed. Changing component.
Note to owner, should tooltips be transparent to all mouse actions?
Component: URL Bar → XP Apps: Drag and Drop
Ever confirmed: true

Comment 8

13 years ago
*** Bug 305053 has been marked as a duplicate of this bug. ***

Comment 9

13 years ago
Confirmed here. Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8b4)
Gecko/20050818 Firefox/1.0+ OS X 10.4.2


13 years ago
OS: Windows 2000 → All
Hardware: PC → All


13 years ago
Target Milestone: --- → mozilla1.5final

Comment 10

13 years ago
I suspect this is a recent regression, at least on Mac. I don't recall ever
being affected by it until recently, and now it trips me up nearly every few
days.  Perhaps the tooltip when hoving over a bookmarks toolbar folder is itself
new? It's also notable that there is NO delay for this tooltip. As soon as the
mouse passes onto the folder, the text pops up, blocking almost all of the target.

This seems reeeeally highly visible for a bug that went without ANY activity for
over three years, until just recently.

No minating as 1.8.1 blocking just to get it re-evaluated (milestone and
assignee both are invalid).
Component: Drag and Drop → Build Config
Flags: blocking1.8.1?

Comment 11

12 years ago
Dito with Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; de; rv: Gecko/20060111 Firefox/

Comment 12

12 years ago
I can confirm that I see this bug in the recent Firefox 2 Mac beta:
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2

I can also confirm that I *DO NOT* see this bug in the same Firefox 2 Linux beta:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1b2) Gecko/20060821 Firefox/2.0b2

Comment 13

12 years ago
Ditto with Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv: Gecko/20060910 SeaMonkey/1.0.5

Comment 14

11 years ago
Tooltip for bookmarks icon (or bookmarks bar) blocks bookmark icon drag and drop into folder on bookmarks bar underlying tooltip.

I have a row of folders on the bookmarks bar that I drag and drop bookmark icons onto for quick sorting. If a bookmark is dragged to a folder on the bookmarks bar whose location is under the (UNWANTED) suddenly appearing tooltip message it DOES NOT Appear in the folder it is dropped upon! 

The Tooltip BLOCKS drag-and-drop bookmark icons dragged from the icon end of the URL address bar to folders on the bookmark bar.

WHY have it show up more than ten times EVER? I don't need to see that damn unwanted tooltip the first 1,000,000 time I go to drag a new bookmark, DO I??!!!??

Can't you let us turn it off????!!!!!

I've had this problem with EVER Version since 1.5 THROUGH and it's nothing new. 

I'd only let that tooltip show up once a month after the first 50 times it is displayed: to display it every single time is needless and annoying. Quickest fix would be to add a preference to allow users to switch all browser functioning tooltips OFF (Leaving all 'titletips' embedded in web pages on, of course) after we know them all by heart. (which takes, what? about 5 minutes ...)

Sad to say some of those sites I TRIED to bookmark I could never find again.

Comment 15

11 years ago
Five years later, this bug is still here! I'm using Intel Mac OS X 10.4.10, Firefox

Does anyone know how to get this bug reassigned? It is currently assigned to "Joe Hewitt (gone)" which doesn't look promising.

Comment 16

11 years ago
It seems that the tooltip text is located in these files:

/browser/locales/en-US/chrome/browser/browser.dtd, line 93 -- <!ENTITY proxyIcon.tooltip "Drag and drop this icon to create a link to this page">
/xpfe/browser/resources/locale/en-US/navigator.dtd, line 185 -- <!ENTITY proxyIcon.tooltip "Drag and drop this icon to create a link to this page">


I'd also like someone to take a look at this. Probably not too complicated but just beyond my puny ability...


11 years ago
Assignee: hewitt → nobody
Component: Build Config → Widget
QA Contact: claudius → general
Comment 9 through comment 16 are bug 312852, a Mac-only regression that happened after Gecko 1.7/Firefox 1.0. This bug was a cross-platform thing that, judging by the comments, only existed for a little while in 2002, so, WFM.
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME

Comment 18

11 years ago
I'm on GNU/Linux. (#16)

Comment 19

10 years ago
Blimey. 2008 and its still here!

I'm using FF 3.03 with XP Pro Sp3.

Why can't this be fixed?
OK, I can set "" to false, but it stops security warnings and other tooltips.

Why can't the developer simply make the tooltip go away whist the user is holding the mouse button down?

This needs fixed people. :-)

Comment 20

9 years ago
how did this bug get the status RESOLVED WORKSFORME ? i'm using 3.5.3 and it's still there!

7 years, still going strong
No, not 7 years. I didn't type comment 17 for the exercise, I typed it so you would know why this is WFM, and is not what you are seeing.

This bug was around for a little while in 2002, followed by four years of the Mac-only bug 312852 from 2005 to 2009, followed by bug 482070, which is likely to be the one you are actually seeing.
You need to log in before you can comment on or make changes to this bug.