an <input> with type"number" working badly with decimal numbers

RESOLVED DUPLICATE of bug 1253606

Status

()

RESOLVED DUPLICATE of bug 1253606
2 years ago
2 years ago

People

(Reporter: agio_, Unassigned)

Tracking

50 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8826223 [details]
firefox input type number.png

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36

Steps to reproduce:

1. go to http://jsfiddle.net/8ZUY4
2. enter a decimal number in the input field (try both . and , as a decimal mark)


Actual results:

Numbers like this 3.14 are accepted but there is a red outline as soon as you write a decimal number (leading zeros are accepted however)

If you write the numbers with a comma as decimal mark like "3,14", it is not even recognized as a number.

It should be noted that my Windows is English and my keyboard and input methods are Norwegian, I don't know if FF checks any of those.

Also if you bump up the font size on the input field, the rocker buttons stay the same size.


Expected results:

No red outline as soon as the number becomes a decimal number. And half the world uses comma as a decimal mark, it should be recognized as a decimal number also.

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1253606
(Reporter)

Comment 2

2 years ago
Sorry bout that, didn't find it. It breaks my Javascript. I'd try to fix it if I knew how :p
You need to log in before you can comment on or make changes to this bug.