Update Thunderbird / IM / SeaMonkey package manifests to reflect typelib filename changes

RESOLVED FIXED in Thunderbird 53.0

Status

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: myk, Assigned: myk)

Tracking

unspecified
Thunderbird 53.0

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
Created attachment 8826294 [details] [diff] [review]
update package manifests for typelib name changes

Bug 1309049 changes the name of one Gecko typelib file (embed_base.xpt is renamed to windowcreator.xpt) and merges another (find.xpt is merged into mozfind.xpt), so the Thunderbird package manifests need to be updated to reflect the changes.

I didn't change any of the removed-files.in files, as we should presumably still remove old embed_base.xpt and find.xpt files in the components/ directory on an application update from an older version of Thunderbird.

However, it isn't clear if I should add the new windowcreator.xpt to Thunderbird's removed-files.in.  Firefox's equivalent of that file removes the entire components/ directory <https://dxr.mozilla.org/mozilla-central/rev/13603af/browser/installer/removed-files.in#90>, so maybe it's still necessary to remove *.xpt files, even new ones.  Requesting needinfo from rstrong on that.

rstrong: do new typelib (*.xpt) files need to be added to removed-files.in for apps like Thunderbird whose removed-files.in enumerates individual files in the components/ directory?
Attachment #8826294 - Flags: review?(jorgk)
Flags: needinfo?(robert.strong.bugs)

Comment 1

2 years ago
Comment on attachment 8826294 [details] [diff] [review]
update package manifests for typelib name changes

Looks good to me. We get busted all the time by people removing .xpt and other files. So it's great to get some heads-up of once ;-)

Usually we just remove whatever got removed in M-C without review and rs=bustage-fix.

I'm not aware of removed-files.in. I've removed plenty of stuff from the package manifest files in the past and never added anything to removed-files.in.

Hmm, let ask someone who should know.
Flags: needinfo?(philip.chee)
Flags: needinfo?(aleth)
Attachment #8826294 - Flags: review?(jorgk) → review+

Comment 2

2 years ago
Richard, this one is interesting four you as well.

Oops, grammar error: So it's great to get some heads-up *for* once ;-)
That line only removes the directory if it is empty and were added to make sure the empty directories were removedon update
https://dxr.mozilla.org/mozilla-central/rev/13603af/browser/installer/removed-files.in#37

It shouldn't be necessary to add an entry to removed-files
Flags: needinfo?(robert.strong.bugs)

Comment 4

2 years ago
To add to rstrong's answer, the mail/ removed-files.in probably still contains a lot of old lines that are no longer required.
Flags: needinfo?(aleth)

Updated

2 years ago
Duplicate of this bug: 1330817

Updated

2 years ago
Summary: update Thunderbird package manifests to reflect typelib filename changes → Update Thunderbird / IM / SeaMonkey package manifests to reflect typelib filename changes
Previous builds already took the last m-c push and there busted.

https://hg.mozilla.org/comm-central/rev/d4fb23de45465e419feb385b79d1e201dcc82759
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 53.0

Comment 7

2 years ago
IIRC the main purpose of removed-files.in was to remove files not needed any more in the transition to zipped omni.jar/omni.ja files. I doubt that anyone (except me) is using a non-omni.ja(r) build of anything.
Flags: needinfo?(philip.chee)

Comment 8

2 years ago
You know maybe we should set up a new top level product in bugzilla for "comm-central" wide changes? I think MailNews/Core is currently way overloaded.
Flags: needinfo?(jorgk)

Comment 9

2 years ago
Hmm, I'm not really a fried of yet another product. In checkin-needed or uplift queries I already have to search five products: Chat Instantbird Thunderbird Mail(news) Calendar.
I'm not even checking SM since you do your own uplifts.

Typically Mailnews has been the overall product, if you want to do a good deed, have Mailnews::General added.
Flags: needinfo?(jorgk)
You need to log in before you can comment on or make changes to this bug.