Check if main ping & environment schemas are up-to-date

RESOLVED FIXED

Status

()

P1
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: gfritzsche, Assigned: Dexter)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox53 affected)

Details

(Whiteboard: [measurement:client])

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
I think we missed some schema updates recently.
Let's check and fix this.
(Assignee)

Updated

2 years ago
Assignee: nobody → alessio.placitelli
Priority: P2 → P1
(Assignee)

Updated

2 years ago
Assignee: alessio.placitelli → nobody
(Assignee)

Updated

2 years ago
Assignee: nobody → alessio.placitelli
(Assignee)

Comment 1

2 years ago
I've added some fields to the main ping schema (processes, events) and fixed a typo for the active experiment [2].

I've fixed the validation notebook [1] and tested that on some recent data. All the pings were correctly validated.

[1] - https://github.com/mozilla-services/mozilla-pipeline-schemas/pull/28
[2] - https://github.com/mozilla-services/mozilla-pipeline-schemas/pull/29
(Assignee)

Comment 2

2 years ago
Georg, do you want to take a sanity check at the updated schema? I'm not sure if you or Mark Reid should review it though.
Flags: needinfo?(gfritzsche)
(Reporter)

Comment 3

2 years ago
Done & left comments. I'd like someone else more involved with the schema work to review though (e.g. mreid).
Flags: needinfo?(gfritzsche)
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1336104
(Assignee)

Comment 5

2 years ago
Created attachment 8834878 [details] [review]
Updated schemas
(Assignee)

Updated

2 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 6

2 years ago
The PR was reviewed, tested and merged.
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.