Animated background GIF no longer displayed

VERIFIED FIXED in mozilla1.0

Status

Core Graveyard
GFX
P2
major
VERIFIED FIXED
16 years ago
10 years ago

People

(Reporter: Steffen Motzer, Assigned: Kevin McCluskey (gone))

Tracking

Trunk
mozilla1.0
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments, 1 obsolete attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.9+)
Gecko/20020323
BuildID:    20020323

When you go to the quick vote section of CNN's webpage and click on "View
Results" a new window opens. In the first of the three frames
(/POLL/templates/homepage.top.exclude.html) an animated GIF is used as the
background image which also includes the close button for the window. Starting
with the latest build Mozilla no longer displays this image.

Could this regression have been caused by the check-in for bug 129908 ?


Reproducible: Always
Steps to Reproduce:
1. go to http://www.cnn.com/
2. click on "View Results" in the quick vote section.

Actual Results:  The upper (first) frame is empty.

Expected Results:  The quick vote banner and the close button should be displayed.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 1

16 years ago
"Could this regression have been caused by the check-in for bug 129908 ?"

I backed out my recent changes to suppress the incremental rendering of
background images in my local tree, rebuilt and the problem still exists:
cvs update -j3.172 -j3.171 mozilla/layout/html/style/src/nsCSSRendering.cpp
cvs update -j3.10 -j3.9 mozilla/layout/base/src/nsImageLoader.cpp
cvs update -j3.8 -j3.7 mozilla/layout/base/src/nsImageLoader.cpp
(Assignee)

Comment 2

16 years ago
Created attachment 75868 [details]
Minimized test case that fails
(Assignee)

Comment 3

16 years ago
Created attachment 75869 [details]
anim gif for test case that works
(Assignee)

Comment 4

16 years ago
Created attachment 75870 [details]
animated background gif test case that works
(Assignee)

Updated

16 years ago
Attachment #75868 - Attachment description: Minimized test case → Minimized test case that fails
(Assignee)

Comment 5

16 years ago
I suspect the problem is caused by a bug in the tiled image rendering. If I
reference the cnn image using a <IMG> element instead of a background attribute
it displays correctly. It may be the size of the tiled image because the small
square animated gear1.gif works when used as a background image.

Reassigning to Don to look at the tiled image rendering code. 
Assignee: kmcclusk → dcone
(Reporter)

Comment 6

16 years ago
I tried to reproduce this bug with "older" nightly builds and found out that
build 20020319-03 still displayed the GIF image. Starting with  build
20020320-03 the background image was no longer shown.
(Assignee)

Comment 7

16 years ago
This bug is a regression caused by the checkin for bug 130027. Fix to follow
shortly.
(Assignee)

Comment 8

16 years ago
Marking nsbeta1+. Any animated gif which is larger than 128 pixels horizontally
or vertically and is used as a background will not render on WINNT, WIN2K, WINXP.
Severity: normal → major
Keywords: nsbeta1+
Priority: -- → P2
Target Milestone: --- → mozilla1.0
(Assignee)

Comment 9

16 years ago
Created attachment 76090 [details] [diff] [review]
Return after the the call to PatBltTile only if PatBltTile returns PR_TRUE otherwise fall through to the progressive doubling algorithm
(Assignee)

Comment 10

16 years ago
Taking this bug since Don is overloaded with other bugs.
Assignee: dcone → kmcclusk
(Assignee)

Updated

16 years ago
Keywords: approval, review

Comment 11

16 years ago
Comment on attachment 76090 [details] [diff] [review]
Return after the the call to PatBltTile only if PatBltTile returns PR_TRUE otherwise fall through to the progressive doubling algorithm

r=dcone.  The reason you can not just fall thru is because the either the width
or height is to large for the progresive doubing.. thats what that check is for
right above it.
Attachment #76090 - Flags: review+

Updated

16 years ago
Attachment #76090 - Flags: review+
(Assignee)

Comment 12

16 years ago
Created attachment 76108 [details] [diff] [review]
Fix which uses the slow tiling instead of progressive doubling since the image exceeded the tiling buffer along one of its dimensions
Attachment #76090 - Attachment is obsolete: true

Comment 13

16 years ago
Comment on attachment 76108 [details] [diff] [review]
Fix which uses the slow tiling instead of progressive doubling since the image exceeded the tiling buffer along one of its dimensions

r=dcone.  I applied and tested this.  It works fine on my win2k.
Attachment #76108 - Flags: review+

Comment 14

16 years ago
Comment on attachment 76108 [details] [diff] [review]
Fix which uses the slow tiling instead of progressive doubling since the image exceeded the tiling buffer along one of its dimensions

sr=attinasi
Attachment #76108 - Flags: superreview+

Comment 15

16 years ago
Comment on attachment 76108 [details] [diff] [review]
Fix which uses the slow tiling instead of progressive doubling since the image exceeded the tiling buffer along one of its dimensions

a=asa (on behalf of drivers) for checkin to the 1.0 trunk
Attachment #76108 - Flags: approval+
(Assignee)

Comment 16

16 years ago
Fix checked in to the trunk
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 17

16 years ago
Marking verified in the April 23 rd build (2002-04-23-06) under Windows ME.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.