Closed Bug 1330967 Opened 3 years ago Closed 3 years ago

Can't open Statistics view through request-list context menu if its open and closed for several times

Categories

(DevTools :: Netmonitor, defect, P1)

53 Branch
defect

Tracking

(firefox50 unaffected, firefox51 unaffected, firefox52 unaffected, firefox53 verified)

VERIFIED FIXED
Firefox 53
Iteration:
53.5 - Jan 23
Tracking Status
firefox50 --- unaffected
firefox51 --- unaffected
firefox52 --- unaffected
firefox53 --- verified

People

(Reporter: ciprian_georgiu, Assigned: steveck)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [netmonitor])

Attachments

(1 file)

[Affected versions]:
- latest Nightly 53.0a1 (2017-01-13)

[Affected platforms]:
- Windows 10 x64
- macOS 10.12.1 Beta
- Ubuntu 16.04 x64 LTS

[Steps to reproduce]:
1. Start Firefox.
2. Go to http://www.bbc.com/ or any website.
3. Open netmonitor by pressing Ctrl + Shift + Q. (or Right click on the page -> Inspect Element -> Network)
4. Choose a request and Right click on it.
5. Pick "Start Performance Analysis..."
6. Close Statistics view with "Back" button from the left side.
7. Repeat steps 4,5,6 for a few times.

[Expected result]:
- Statistics view with Chart pie is open every time is pressed "Start Performance Analysis..." from context menu.

[Actual result]:
- Statistics view is not displayed.

[Regression range]:
Last good revision: 77b7f79852e0ad77d8a92927646975ef60efc194
First bad revision: 410e5d477c0d13e38092421cd02c899f81423065
Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=77b7f79852e0ad77d8a92927646975ef60efc194&tochange=410e5d477c0d13e38092421cd02c899f81423065

Looks like the following bug has the changes which introduced the regression:
https://bugzilla.mozilla.org/show_bug.cgi?id=1308697

[Additional notes]:
- you can also hit this bug by clicking the requests near "Filter URLs" (and same STR) instead on "Start Performance Analysis..." from context menu
Hm..., I can't reproduce it on my machine: Win10 64 bit, 53.0a1 (2017-01-13) (64-bit)

The Statistics view appears every time I pick "Start Performance Analysis..."

What could be different in our configs?

Honza
OK, after chatting on IRC with Ciprian I was able to reproduce this issue.

Here is a GIF from Ciprian:
http://imgur.com/a/yLp1u

And a comment:
I couldn't see the problem with my simple test page but, it's visible with cnn.com (as mentioned in comment #0). It looks like the problem is there if you start the performance analysis while the page is still loading.

@Steve: can you please take a look at this?

(I am using P2, but should be P1 as soon as we have a slot in our MVP list)

Honza
Has STR: --- → yes
Flags: needinfo?(schung)
Priority: -- → P2
I'll take a look ASAP.
Assignee: nobody → schung
Status: NEW → ASSIGNED
Flags: needinfo?(schung)
Iteration: --- → 53.5 - Jan 23
Flags: qe-verify+
Priority: P2 → P1
Hi Honza,

Although it could be replaced with "gStore.dispatch(Actions.openStatistics(false))", I still removed this part because I don't think it's necessary to open the request list view every time while receiving the will-navigate event during loading.
Comment on attachment 8827088 [details]
Bug 1330967 - Can not open Statistics view after switching between 2 views several times,

https://reviewboard.mozilla.org/r/104918/#review105668

Looks good but, is the 'devtools/client/netmonitor/test/browser_net_statistics-02.js' failure seems to be related.

Honza
Attachment #8827088 - Flags: review?(odvarko)
@Ciprian: does this patch fixes the problem for you? You can download Firefox build here (with the patch included):

https://archive.mozilla.org/pub/firefox/try-builds/schung@mozilla.com-76774147049cf8782ef5afddec907a27a75a7b7a/try-win64/

Honza
Flags: needinfo?(ciprian.georgiu)
Yes it does. I've spent the last 15 minutes trying to reproduce this again, but with no luck. :)

Thanks!
Flags: needinfo?(ciprian.georgiu)
(In reply to Ciprian Georgiu, QA [:ciprian_georgiu] from comment #8)
> Yes it does. I've spent the last 15 minutes trying to reproduce this again,
> but with no luck. :)
Thanks!


So, looks like only the test failure needs to be resolved.

Honza
It seems like we don't need the browser_net_statistics-02.js at all if we decide to "avoid" switching back to list view, since it's mainly validating this behavior. So there's some possible solution:
- Remove the test file
- Change the panel switching to gStore.dispatch(Actions.openStatistics(false)), and we could have the exactly some behavior like before. But you will see the statistic view switch back repeatedly in the cnn website(and previous version has the same issue).

I'll do the (1) first, but please let me know if you change your mind.
Comment on attachment 8827088 [details]
Bug 1330967 - Can not open Statistics view after switching between 2 views several times,

https://reviewboard.mozilla.org/r/104918/#review105862

Yep, works for me (removing the test is fine), thanks Steve for fixing this!

R+, assuming try is green now.

Honza
Attachment #8827088 - Flags: review?(odvarko) → review+
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/1d88fc311d4b
Can not open Statistics view after switching between 2 views several times, r=Honza
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/1d88fc311d4b
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 53
Verified fixed on 53.0a2 (20170124223930) across platforms:
- Windows 10 x64
- Mac OS X 10.11.6
- Ubuntu LTS 16.04 x64
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.