Closed Bug 1331051 Opened 3 years ago Closed 3 years ago

[Firefox 50.1.0] Animated PNGs replace parts of the image that aren't redrawn between frames with transparency

Categories

(Core :: ImageLib, defect)

50 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1319025

People

(Reporter: kirbywarriorfan_1_, Unassigned)

Details

(Keywords: testcase-wanted)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20161208153507

Steps to reproduce:

I tried to load an animated PNG that was optimized (meaning certain parts of the image are not redrawn between frames) using Firefox 50.1.0.


Actual results:

Parts of the image that are not redrawn between frames were replaced with transparency.


Expected results:

The non-redrawn areas should remain visually the same as in previous frames of the PNG, without turning transparent, until they are redrawn.
Can you attach the offending APNG, please.

Anyway, I suspect it's a dupe of bug 1319025.
Component: Activity Streams: General → ImageLib
Flags: needinfo?(kirbywarriorfan_1_)
Keywords: testcase-wanted
Product: Firefox → Core
Version: unspecified → 50 Branch
Yes, it's a duplicate of that bug.
Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Flags: needinfo?(kirbywarriorfan_1_)
Resolution: --- → DUPLICATE
Duplicate of bug: 1319025
You need to log in before you can comment on or make changes to this bug.