netscape.com - mouse icon is not a hand when over javascript links

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
English US
P4
trivial
RESOLVED WORKSFORME
16 years ago
3 years ago

People

(Reporter: Theblueman, Assigned: Doron Rosenberg (IBM))

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9+) Gecko/20020323
BuildID:    20020323-21

When the mouse hovers over a javascript link the pointer icon should be a hand
to indicate it is a link.  In the link above the hand does not appear.  

Reproducible: Always
Steps to Reproduce:
1.Go to the link http://home.netscape.com/ex/shak/shopping/index.html 
2.On the left side hover over the javascript menus.
3.the pointer icon should be a hand over the links but it is not.

Actual Results:  The pointer icon is the one one used for text selection.

Expected Results:  When hovering over the links the mouse icon should be the
hand to indicate that it is an active link.

I noticed the same thing in windows as well.  Netscape 4 and IE display the
pointer correctly.

Comment 1

16 years ago
confirming using build 2002032203 on Win2k.
OS: Linux → All
Hardware: PC → All
->layout?
Assignee: rogerl → attinasi
Status: UNCONFIRMED → NEW
Component: JavaScript Engine → Layout
Ever confirmed: true
QA Contact: pschwartau → petersen

Comment 3

16 years ago
dupe of bug 88688?

Comment 4

16 years ago
or it might be a dupe of bug 129350
probably this one because i did not fine cursor: auto styles in any of the
stylesheets.

*** This bug has been marked as a duplicate of 129350 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 6

16 years ago
Changing QA contact
QA Contact: petersen → moied
(Reporter)

Comment 7

16 years ago
I noticed bug 129350 was marked as resolved but it didn't fix the original
problem with the URL http://home.netscape.com/ex/shak/shopping/index.html
The links still have the editor cursor instead of the hand.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Updated

16 years ago
Priority: -- → P4
Target Milestone: --- → Future

Comment 8

16 years ago
This is not a bug as far as I see it.
If you look at the page in DOM Inspector of try to actually look through the
javascript code ( see Flyout function ), you will see that the the menu is
generated by creating a <div> for each item in the menu and placing onmouseover,
onmouseout, onclick handlers on the div.
They are *not* links but just regular elements written to *act* like links.

I think this bug should be resolved as INVALID since there's no bug after all,
but this is expected behaviour.

Comment 9

16 years ago
BTW. The reason it works in IE is because of the cursor: hand property which is
not part of CSS2 standard.

http://www.w3.org/TR/REC-CSS2/ui.html#propdef-cursor

Comment 10

16 years ago
So what can we do with this bug?

Can't Netscape modify their site to send 'cursor: pointer' when the ua is gecko?

Comment 11

16 years ago
-> evang.

(100% not a bug in mozilla)
Assignee: attinasi → doron
Status: REOPENED → NEW
Component: Layout → US General
Product: Browser → Tech Evangelism
QA Contact: moied → zach
Target Milestone: Future → ---
Version: other → unspecified

Comment 12

16 years ago
->evang500
Keywords: evang500

Updated

16 years ago
Blocks: 118291
Summary: mouse icon is not a hand when over javascript links → netscape.com - mouse icon is not a hand when over javascript links

Comment 13

16 years ago
Site was totally redesigned.
Status: NEW → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.