Closed Bug 1331151 Opened 5 years ago Closed 5 years ago

Flexible box elements are not paged in the print-preview

Categories

(Core :: Layout, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1622935
Tracking Status
firefox53 --- affected

People

(Reporter: yuki, Unassigned)

Details

Attachments

(1 file)

Elements rendered as CSS flexible boxes are not paged to multiple pages. I couldn't determine whether it is a bug of Gecko or the spec: https://dev.w3.org/csswg/css-flexbox/

Steps to reproduce:
1. Create a  page with flexible boxes:
~~~
<!DOCTYPE html>
<style type="text/css">
body {
  margin: 0;
  padding: 0;
}
main {
  display: flex;
}
article {
  flex: 1 1 auto;
}
section {
  width: calc(210mm - 10mm);
  height: calc(297mm - 10mm);
  border: 5mm solid red;
}
@page {
  size: A4;
  margin: 0;
}
</style>
<body>
  <main>
    <article>
      <section>1</section>
      <section>2</section>
      <section>3</section>
    </article>
  </main>
</body>
~~~
2. Open the testcase.
3. Go to print preview.

Actual result:
There is only one page and only the first section appears.

Expected result:
There are three pages and all three sections appear.

Additional information:
The testcase is rendered as expected in Google Chrome's print preview.
Attached file The testcase
In Firefox's print preview, secondary and after sections are placed at the outside area of the first page. Actually, you'll confirm that by adding some CSS rules like "position: relative; top: -50mm" to the secondary <section> element.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 939897

Printing a single-line row flex container is fixed by bug 1622935. The patch is already in Firefox Nightly (2020-05-14).

Duplicate of bug: 1622935
You need to log in before you can comment on or make changes to this bug.